Closed Bug 1349798 Opened 3 years ago Closed 3 years ago

[css-grid] fixed-width grid-item ignores overflow: hidden property

Categories

(Core :: Layout, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1348857
Tracking Status
firefox55 --- affected

People

(Reporter: hunboy, Assigned: mats)

Details

(Keywords: testcase)

Attachments

(2 files)

spec: https://drafts.csswg.org/css-grid/#min-size-auto

intristic width on fix sized grid-item with overflow: hidden still visible.

testcase attached
per discuss on chat, I upload this testcase as well, but modified a little.
now overflow-x: hidden only. It also causes cross-browser issue, on chromium canary with this testcase the submenu behaves as overflow-x: auto. So looks to me, the chromum has bug as well.

So would be clarify this one also.
Assignee: nobody → utasir
Flags: needinfo?(mats)
Assignee: utasir → nobody
Thanks for your bug report, this will be fixed by bug 1348857 (in v54 hopefully).
The horizontal scrollbar in the second testcase is expected because 'overflow-x'
computes to 'auto' unless specified when 'overflow-y' is non-visible, per:
https://drafts.csswg.org/css-overflow-3/#overflow-properties
"Computed value: 	as specified, except with visible computing to auto if one of overflow-x or overflow-y is not visible"
Assignee: nobody → mats
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(mats)
Keywords: testcase
Resolution: --- → DUPLICATE
Duplicate of bug: 1348857
You need to log in before you can comment on or make changes to this bug.