Closed Bug 1349874 Opened 4 years ago Closed 3 years ago

High CPU usage and crash with WebExtension native messaging

Categories

(WebExtensions :: Untriaged, defect, P3)

54 Branch
x86_64
Linux
defect

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: ykonotopov, Unassigned)

References

Details

(Whiteboard: triaged)

Crash Data

Attachments

(3 files)

Attached file firefox-crash-1.log
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/57.0.2987.98 Safari/537.36

Steps to reproduce:

Installed GNOME Shell integration [1] browser extension on Ubuntu 16.04



Actual results:

Firefox consumes a lot of CPU and crash on exit.


Expected results:

No crash should occure.

This was twice [2][3] repored against GNOME Shell integration browser extension. However I can not reproduce this by myself.

Debugging in [2] we found that native host messaging app exits normally. Also there are no problems with Chromium.

I attached Firefox console output provided by users.

This may be related to [4] or [5].

[1] https://addons.mozilla.org/firefox/addon/gnome-shell-integration
[2] https://github.com/nE0sIghT/chrome-gnome-shell-mirror/issues/49
[3] https://github.com/nE0sIghT/chrome-gnome-shell-mirror/issues/53
[4] https://bugzilla.mozilla.org/show_bug.cgi?id=1337799
[5] https://bugzilla.mozilla.org/show_bug.cgi?id=1342850
Attached file firefox-crash-2.log
Crash log from another user
Component: Untriaged → WebExtensions: Untriaged
OS: Unspecified → Linux
Product: Firefox → Toolkit
Hardware: Unspecified → x86_64
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1342850
I'm clearing duplicate state since this issue is reproducible with my fully updated Gentoo system.
I reproduced this issue both with current stable and developer versions.

Steps to reproduce:

1. Install GNOME Shell integration browser extension [1]
2. Install native host messaging connector [2]
3. Open browser with "-jsdebugger" option. Without this option issue occurs from time to time.
4. Close browser

Expected results:
Browser closed normally.

Actual results:
Browser process consumes a lot of CPU cycles and crash.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Version: 52 Branch → 54 Branch
Attached crash report
Crash Signature: bp-a1d8490a-3bda-4af4-a278-c5b6c0170425
Duplicate of this bug: 1337799
Updated steps to reproduce:

1. Install GNOME Shell integration browser extension [1]
2. Install native host messaging connector [2]
3. Open browser with "-jsdebugger" option. Without this option issue occurs from time to time.
4. Close browser

Expected results:
Browser closed normally.

Actual results:
Browser process consumes a lot of CPU cycles and crash.

[1] https://addons.mozilla.org/firefox/addon/gnome-shell-integration/
[2] https://wiki.gnome.org/Projects/GnomeShellIntegrationForChrome/Installation
Priority: -- → P3
Whiteboard: triaged
What can I do to help? This bug is a doozey; it's wasting so many CPU cycles and power in the world for anyone using this plugin (most people aren't probably noticing anything is wrong until they see the crash upon trying to close Firefox)
(In reply to fermulator from comment #9)
> What can I do to help? This bug is a doozey; it's wasting so many CPU cycles
> and power in the world for anyone using this plugin (most people aren't
> probably noticing anything is wrong until they see the crash upon trying to
> close Firefox)

FYI I have some OS data here https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/1576581
(although Yuri's report is far more useful with the technical crash data and logs)
IS this on anyone from Mozilla's radar?
Looks like this issue was fixed around version 55.
Only 52 ESR users are affected.
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago3 years ago
Resolution: --- → WORKSFORME
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.