Closed Bug 1349892 Opened 3 years ago Closed 8 months ago

Intermittent browser_ext_sidebarAction_context.js | Test timed out

Categories

(WebExtensions :: Frontend, defect, P1)

defect

Tracking

(firefox67 fixed)

RESOLVED FIXED
mozilla67
Tracking Status
firefox67 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: rpl)

References

Details

(Keywords: intermittent-failure, Whiteboard: [stockwell fixed])

Attachments

(2 files)

Component: General → WebExtensions: Frontend
Product: Firefox → Toolkit
See Also: → 1208596
Priority: -- → P5
See Also: → 1455936
Product: Toolkit → WebExtensions
Summary: Intermittent browser/components/extensions/test/browser/browser_ext_sidebarAction_context.js | Test timed out - → Intermittent browser_ext_sidebarAction_context.js | Test timed out
Duplicate of this bug: 1455936

There are 49 total failures in the last 7 days, this spike seems to have started on the 6th of February:

https://treeherder.mozilla.org/intermittent-failures.html#/bugdetails?startday=2019-01-11&endday=2019-02-10&tree=all&bug=1349892

David can you take a look at this or assign someone?

Flags: needinfo?(ddurst)
Whiteboard: [stockwell needswork:owner]
Pushed by rgurzau@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3150818d30f6
Disable browser_ext_sidebarAction_context.js on all platforms. r=aryx

Setting P1, because this is now disabled on all platforms.

Assignee: nobody → lgreco
Flags: needinfo?(ddurst)
Priority: P5 → P1
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
Whiteboard: [stockwell disable-recommended] → [stockwell disabled]

This test was intermittently timing out, mostly on debug builds, because there
was a chance that from time to time the sidebar could have been loaded for the
first time while the background page of the test extension was still being loaded.

The test was sending an extension test message as soon as the sidebar was loaded
for the first time, and so if the background page didn't yet added its test message
listener, the test cases did never get started and the entire test was getting stuck.

The changes included in this patch prevents this intermittent failures by ensuring
that the test always waits for the background page and the sidebar to be both loaded
and ready before sending the test message that starts to run the test cases.

Pushed by luca.greco@alcacoop.it:
https://hg.mozilla.org/integration/autoland/rev/479a97f57877
Fix browser_ext_sidebarAction_contex intermittency. r=mixedpuppy
Whiteboard: [stockwell disabled] → [stockwell fixed]

From my understanding this issue is related to the addon tests. Is there any need of manual QA here? If not can you please mark it as "qe-verify- "

Flags: needinfo?(lgreco)
Flags: needinfo?(lgreco) → qe-verify-
You need to log in before you can comment on or make changes to this bug.