Today view widget buttons misaligned

RESOLVED WORKSFORME

Status

()

Firefox for iOS
General
P3
normal
Rank:
3
RESOLVED WORKSFORME
a year ago
2 months ago

People

(Reporter: Jacob White, Unassigned)

Tracking

unspecified
Other
iOS

Firefox Tracking Flags

(fxios9.0)

Details

(Whiteboard: [MobileCore][VisualPolish][Today])

Attachments

(4 attachments)

(Reporter)

Description

a year ago
Created attachment 8850603 [details]
IMG_4434.PNG

User Agent: Mozilla/5.0 (iPhone; CPU iPhone OS 10_3 like Mac OS X) AppleWebKit/603.1.23 (KHTML, like Gecko) FxiOS/6.1 Mobile/14E5239e Safari/603.1.23

Steps to reproduce:

View the widget in today view.


Actual results:

"New Private Tab" is higher than the "New Tab" button.

Sometimes the button will move up after appearing misaligned initially.


Expected results:

They should be vertically aligned.
tracking-fxios: --- → ?
Could this be a device or version specific related? 
I checked with latest Nightly (master 7f52d8f) and looks ok
Created attachment 8851981 [details]
Captura de pantalla 2017-03-28 a las 14.32.10.png
Assignee: nobody → irios.mozilla
Assignee: irios.mozilla → nobody
Btw, screenshot taken on iPhone 6 10.2 simulator, also checked on iPod Touch 10.2 device with Nightly and with Firefox 6.1 (1)
(Reporter)

Comment 4

a year ago
After more observation, I've noticed sometimes the buttons are okay, sometimes they're misaligned, and sometimes they're squished vertically.

Could be device specific but is happening in all the versions I've checked.
Oh ok, thanks for the info! I will access that menu frequently to be able to reproduce
tracking-fxios: ? → 8.0+
Priority: -- → P3
Whiteboard: [MobileCore]
tracking-fxios: 8.0+ → 9.0
Rank: 3
Closing. Please re-open if this shows up again.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 7

a year ago
It’s still broke for me 
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: WORKSFORME → ---
Whiteboard: [MobileCore] → [MobileCore][VisualPolish]

Updated

11 months ago
Whiteboard: [MobileCore][VisualPolish] → [MobileCore][VisualPolish][Today]
I'm unable to reproduce this.

Significant change has happened since 6.1. 

:jacob – could you confirm it's still broken, with a screenshot and some details of the device you are seeing this on. Once you have that, please reopen this bug.
Status: REOPENED → RESOLVED
Last Resolved: a year ago9 months ago
Flags: needinfo?(me)
Resolution: --- → WORKSFORME
(Reporter)

Comment 10

2 months ago
Created attachment 8969491 [details]
6F14ED38-27C1-4317-A6BF-FD9E3540A906.MOV

This is slightly different from what I was seeing before, but is more reproducible. iPhone X
Flags: needinfo?(me)
You need to log in before you can comment on or make changes to this bug.