Closed Bug 1350315 Opened 3 years ago Closed 3 years ago

Html5-video mouse does not hide when in fullscreen

Categories

(Firefox :: General, defect, minor)

53 Branch
x86_64
Windows 7
defect
Not set
minor

Tracking

()

VERIFIED FIXED
Firefox 55
Tracking Status
firefox-esr45 --- unaffected
firefox52 --- unaffected
firefox-esr52 --- unaffected
firefox53 + verified
firefox54 + verified
firefox55 --- verified

People

(Reporter: wip.the.gruik, Assigned: ralin)

References

Details

(Keywords: regression)

Attachments

(1 file)

Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:53.0) Gecko/20100101 Firefox/53.0
version 53.0b5 - build id 20170320143328

Reproducible with 55-beta5 x64 on Windows 7 x64.

Steps to reproduce:
 - open a simple "<video> tagged" video
   e.g. https://www.iandevlin.com/html5test/webvtt/html5-video-webvtt-sample.html 
 - start playing the video
 - switch to fullscreen (double-click on the container or use the dedicated button)
 - move the mouse to ensure it is displayed

Actual results:
 the mouse cursor do not hide when the controls do, or whatever the time you wait

Expected results:
 the mouse cursor hide itself when the controls hide or after a short delay

In Firefox 52 (former video controls) when double-clicking to go fullscreen the mouse is instantly hidden (as the controls), whereas with beta 53 (new video controls) the mouse cursor stay visible when switching to fullscreen (but controls are hidden).
[Tracking Requested - why for this release]: UX regression, mouse pointer would not hide in fullscreen video.

Regression window:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=ec7fb4f14d3ec23ded7eea40ff49ebbcbec6bde1&tochange=8d2eecb7ea5a16e02862dd326ce4519082ce9901

Regressed by: Bug 1271765
Blocks: 1271765
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(ralin)
Keywords: regression
Ray, can you take a look here? It would be nice to fix this for 53 if possible. If not, maybe aim for uplift to 54.   It is nicer watching full screen videos without the cursor showing!
Assignee: nobody → ralin
Status: NEW → ASSIGNED
Flags: needinfo?(ralin)
(In reply to Liz Henry (:lizzard) (needinfo? me) from comment #2)
> Ray, can you take a look here? It would be nice to fix this for 53 if
> possible. If not, maybe aim for uplift to 54.   It is nicer watching full
> screen videos without the cursor showing!

Thanks, in agreement with watching full screen video without cursor :)
I've pushed one rule CSS fix, and hopefully can uplift to 53 as possible.
Attachment #8851189 - Flags: review?(jaws) → review?(gijskruitbosch+bugs)
Comment on attachment 8851189 [details]
Bug 1350315 - Hide cursor when video controls fadeout for desktop.

https://reviewboard.mozilla.org/r/123550/#review126092

Stealing this to ease Jared's review load.

Shouldn't we also remove https://dxr.mozilla.org/mozilla-central/source/toolkit/content/widgets/videocontrols.css#33 ? Or, better yet, why can't we just update that rule so it matches?
Attachment #8851189 - Flags: review?(gijskruitbosch+bugs) → review-
(In reply to :Gijs from comment #5)
> Comment on attachment 8851189 [details]
> Bug 1350315 - Hide cursor when video controls fadeout for desktop.

> Shouldn't we also remove
> https://dxr.mozilla.org/mozilla-central/source/toolkit/content/widgets/
> videocontrols.css#33 ? Or, better yet, why can't we just update that rule so
> it matches?

yeah, it should have been removed. I thought we still need this for mobile, but I didn't think of users normally don't have cursor in Android at that time. :-D  Thanks.
Comment on attachment 8851189 [details]
Bug 1350315 - Hide cursor when video controls fadeout for desktop.

https://reviewboard.mozilla.org/r/123550/#review126224
Attachment #8851189 - Flags: review?(gijskruitbosch+bugs) → review+
Keywords: checkin-needed
Comment on attachment 8851189 [details]
Bug 1350315 - Hide cursor when video controls fadeout for desktop.

Approval Request Comment
[Feature/Bug causing the regression]: Bug 1271765
[User impact if declined]: cursor won't hide after entering fullscreen
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: no
[Needs manual test from QE? If yes, steps to reproduce]: no
[List of other uplifts needed for the feature/fix]: none
[Is the change risky?]: low risk
[Why is the change risky/not risky?]: only one css rule added
[String changes made/needed]: none

Thanks!
Attachment #8851189 - Flags: approval-mozilla-beta?
Attachment #8851189 - Flags: approval-mozilla-aurora?
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/28f5bbc4995d
Hide cursor when video controls fadeout for desktop. r=Gijs
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/28f5bbc4995d
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
Comment on attachment 8851189 [details]
Bug 1350315 - Hide cursor when video controls fadeout for desktop.

Fix a regression that cursor won't hide in fullscreen. Aurora54+ & Beta53+.
Attachment #8851189 - Flags: approval-mozilla-beta?
Attachment #8851189 - Flags: approval-mozilla-beta+
Attachment #8851189 - Flags: approval-mozilla-aurora?
Attachment #8851189 - Flags: approval-mozilla-aurora+
Flags: qe-verify+
I have reproduced this bug with Nightly 55.0a1(2017-03-24) on Windows 10, 64 bit!

The Bug's fix is now verified on Latest 

Nightly 55.0a1
Build ID 	20170329030240
User Agent 	Mozilla/5.0 (Windows NT 10.0; WOW64; rv:55.0) Gecko/20100101 Firefox/55.0

Aurora  54.0a2
Build ID 	20170329004027
User Agent 	Mozilla/5.0 (Windows NT 10.0; WOW64; rv:54.0) Gecko/20100101 Firefox/54.0


But the issue is reproducible in Beta 53.0b7
Build ID 	20170327081421
User Agent 	Mozilla/5.0 (Windows NT 10.0; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0

[bugday-20170329]
(In reply to Tanvir Rahman from comment #15)
> But the issue is reproducible in Beta 53.0b7
> Build ID 	20170327081421
> User Agent 	Mozilla/5.0 (Windows NT 10.0; WOW64; rv:53.0) Gecko/20100101
> Firefox/53.0


I think we would need to wait for next beta release to see the fix applied, as the patch was uplifted yesterday(0328) which a bit latter than Build 20170327. Thanks you :)
[bugid-20170329] i tried to reproduce your bug...the bug has been fixed
I have reproduced this issue using Firefox 52.0.1 (ID=20170307064827) on Win 8.1 x64.
I can confirm this issue is fixed, I verified using Firefox 53.0b8, 54.0a2 on Win 7 x64, Win 8.1 x64, Mac OS X 10.10 and Ubuntu 16.04 x64.
[bugid-20170322] 
Operating System: Windows 10(64 bit)
Browser: Firefox Nightly 54.0a2

The bug has been fixed and verified!
(In reply to surentharan14 from comment #17)
(In reply to Timea Zsoldos from comment #18)
(In reply to Moneshb7 from comment #19)

Thanks :D
Marking this bug as Verified Fixed (based on comment 18).
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.