Closed Bug 135048 Opened 18 years ago Closed 18 years ago

Folder pane won't auto scroll down during drag and drop

Categories

(Core :: XUL, defect, P2)

x86
Windows NT
defect

Tracking

()

VERIFIED FIXED
mozilla1.0

People

(Reporter: scottputterman, Assigned: janv)

References

Details

(Keywords: regression, Whiteboard: [adt2])

Attachments

(1 file)

Using the 4/1 build on Win NT.

1.  Make sure your folder pane has enough folders to have a scrollbar.
2.  Select a message in the thread pane and drag it over to the folder pane.
3.  Drag it to the bottom of the folder pane.

Expected:  The folder pane should start auto scrolling downwards.
Result:  Nothing.

Dragging to the top causes the folder pane to auto scroll up.  I see the same
results in the address book directory pane.
Keywords: nsbeta1+
Priority: -- → P2
Whiteboard: [adt2]
Target Milestone: --- → mozilla1.0
mine
Assignee: ssu → varga
Component: Mail Window Front End → XP Toolkit/Widgets: Trees
Keywords: regression
Product: MailNews → Browser
Thanks for taking this bug.  I was looking to see if there was one already filed
against xp toolkits.

This problem also shows up when trying to drag&drop a url (from the url bar) to
the bookmarks in the sidebar panel.  It won't autoscroll down, only up.
Attached patch proposed fixSplinter Review
Comment on attachment 77830 [details] [diff] [review]
proposed fix

r=bryner
Attachment #77830 - Flags: review+
Comment on attachment 77830 [details] [diff] [review]
proposed fix

a=asa (on behalf of drivers) for checkin to the 1.0 trunk with the hope that
this fixes or makes a lot better the problem at bug 134889.
Attachment #77830 - Flags: approval+
Landed on the trunk.
Jan, can you please land this on the branch as well? a=asa. Thanks.

Landed on the branch.
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → FIXED
OK using apr23 branch build: win98, linux rh6.2, mac OS 10.1
OK using apr23 trunk commercial build: win98, linux rh6.2
Status: RESOLVED → VERIFIED
QA Contact: olgam → laurel
adding fixed1.0.0 keyword (branch resolution). This bug has comments saying it
was fixed on the 1.0 branch and a bonsai checkin comment that agrees. To verify
the bug has been fixed on the 1.0 branch please replace the fixed1.0.0 keyword
with verified1.0.0.
Keywords: fixed1.0.0
*** Bug 135246 has been marked as a duplicate of this bug. ***
OK using june7 commercial branch build: win98, mac OS 9.2, linux rh6.2
Component: XP Toolkit/Widgets: Trees → XUL
QA Contact: laurel → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.