Closed Bug 1350644 Opened 3 years ago Closed 3 years ago

Remove the PBlob::Msg_WaitForSliceCreation sync IPC

Categories

(Core :: DOM: Core & HTML, enhancement, P1)

enhancement

Tracking

()

RESOLVED DUPLICATE of bug 1359718

People

(Reporter: ehsan, Assigned: baku)

References

(Blocks 1 open bug)

Details

(Whiteboard: [qf:p1])

Median time: 21ms.  :(

It seems that in the content process, the creation of a Blob is always blocking, if I'm reading <http://searchfox.org/mozilla-central/rev/7419b368156a6efa24777b21b0e5706be89a9c2f/dom/file/ipc/Blob.cpp#3583> correctly.
baku knows lots about Blobs.
Assignee: nobody → amarchesini
Priority: -- → P1
This is part of the PBlob refactoring.
Blocks: 1353629
Whiteboard: [qf]
Whiteboard: [qf] → [qf:p1]
Blocks: 1360185
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1359718
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.