If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Adding specific themes leads to error in rendering the the tabs and browser functionalities

RESOLVED DUPLICATE of bug 1344839

Status

()

Firefox
Theme
RESOLVED DUPLICATE of bug 1344839
7 months ago
7 months ago

People

(Reporter: Pouyan, Unassigned)

Tracking

54 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 months ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:54.0) Gecko/20100101 Firefox/54.0
Build ID: 20170326084824

Steps to reproduce:

Go to this Firefox Theme:

https://addons.mozilla.org/en-US/firefox/addon/mz-aurora/

Move your mouse over the theme for the preview.

There are also other themes that show the same problem. And adding the theme make this effect permanent. You have to start browser in safe-mode, remove the theme and start it again.





Actual results:

The browser has some glitches in showing the theme, but afterwards, the tab currently open and other tabs show the loading circle with no rendering.

In Linux Terminal the following errors are listed:

----
IPDL protocol error: Handler returned error code!

###!!! [Parent][DispatchAsyncMessage] Error: PLayerTransaction::Msg_ReleaseLayer Processing error: message was deserialized, but the handler returned false (indicating failure)

IPDL protocol error: Handler returned error code!

###!!! [Parent][DispatchAsyncMessage] Error: PLayerTransaction::Msg_ReleaseLayer Processing error: message was deserialized, but the handler returned false (indicating failure)

IPDL protocol error: Handler returned error code!

###!!! [Parent][DispatchAsyncMessage] Error: PLayerTransaction::Msg_ReleaseLayer Processing error: message was deserialized, but the handler returned false (indicating failure)

IPDL protocol error: Handler returned error code!
---
###!!! [Parent][DispatchAsyncMessage] Error: PLayerTransaction::Msg_ReleaseLayer Processing error: message was deserialized, but the handler returned false (indicating failure)



Expected results:

Add the theme and show the tab open.

Comment 1

7 months ago
Reproducible on Ubuntu 16.04 with latest nightly.
Status: UNCONFIRMED → NEW
Component: Untriaged → Theme
Ever confirmed: true
99% sure this is a dupe of bug 1344839.
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1344839
You need to log in before you can comment on or make changes to this bug.