Tabs become blank after previewing themes

RESOLVED DUPLICATE of bug 1344839

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 1344839
a year ago
a year ago

People

(Reporter: mat, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
STR:
- Open https://addons.mozilla.org/en-US/firefox/themes/ and hover your cursor over a few themes

Expected Results:
- Each theme is previewed correctly

Actual Results:
- Some themes are previewed correctly, but at some point when hovering a theme the tab content becomes entirely blank, and nothing brings it back. It's still possible to interact with it, click on links etc, but the content is invisible.

I can reproduce this on a fresh profile on Firefox 55 (Nightly 20170328110211) on Linux. I can *not* reproduce on 52.0.1 release on the same system. This has been confirmed by at least 2 other users using Linux in https://github.com/mozilla/addons-server/issues/5019 and https://github.com/webcompat/web-bugs/issues/5268 ; I asked on IRC and at least one person could not reproduce on Windows.
(Reporter)

Comment 1

a year ago
ni? some people that might be able to help (thanks, padenot)
Flags: needinfo?(jaws)
Flags: needinfo?(dao+bmo)

Comment 2

a year ago
Can you find a regression window with https://mozilla.github.io/mozregression/ ?
Component: Theme → Untriaged
Flags: needinfo?(mpillard)

Comment 3

a year ago
Firefox::Theme is generally for bugs in the themes we ship. I don't think that's at fault here. Maybe the toolkit lightweighttheme code is broken, but I actually suspect this will end up being a graphics bug.

A screenshot would also be helpful.
Flags: needinfo?(jaws)
Flags: needinfo?(dao+bmo)
(Reporter)

Comment 4

a year ago
Created attachment 8852052 [details]
tab-disappearing.webm

I don't see anything in my browser or web console, but the terminal I started nightly from shows:
IPDL protocol error: Handler returned error code!

###!!! [Parent][DispatchAsyncMessage] Error: PLayerTransaction::Msg_ReleaseLayer Processing error: message was deserialized, but the handler returned false (indicating failure)

Attached is a video showing the issue. Note that all existing tabs are affected as well. I'll try to figure out a regression range.
Flags: needinfo?(mpillard)
(Reporter)

Comment 5

a year ago
Mozregression results:
 8:11.41 INFO: Last good revision: e91de6fb2b3dce9c932428265b0fdb630ea470d7
 8:11.41 INFO: First bad revision: 180a160ae22a4d63867cfd02608e7621e8e697d1
 8:11.41 INFO: Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=e91de6fb2b3dce9c932428265b0fdb630ea470d7&tochange=180a160ae22a4d63867cfd02608e7621e8e697d1
This is a dupe of bug 1344839. I'll update the summary of that bug so it has better keywords :)
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1344839
You need to log in before you can comment on or make changes to this bug.