Closed Bug 1351588 Opened 3 years ago Closed 3 years ago

::first-line skips contents inside display:contents

Categories

(Core :: CSS Parsing and Computation, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1305951

People

(Reporter: Oriol, Unassigned)

Details

Attachments

(1 file)

Attached file testcase
Consider this code:

    <style>
    div {
      color: red;
    }
    div::first-line {
      color: green;
    }
    span {
      display: contents;
    }
    </style>
    <div>
      Foo <span>Bar</span> Baz
    </div>

Only Foo and Baz are green. Bar is red.
Component: Layout → CSS Parsing and Computation
See Also: → 1351595
See Also: 1351595
No longer blocks: 907396
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1305951
You need to log in before you can comment on or make changes to this bug.