[fxa][Staging 83] Verification not always received when creating a new account

RESOLVED WORKSFORME

Status

Cloud Services
QA: General
RESOLVED WORKSFORME
a year ago
a year ago

People

(Reporter: Ninu, Unassigned)

Tracking

unspecified
Unspecified
Windows 7
Points:
---

Firefox Tracking Flags

(fennec-, firefox53 wontfix, firefox54+ wontfix, firefox55+ wontfix)

Details

(Reporter)

Description

a year ago
Platform Desktop
Windows 10, windows 7 (Both on 64)
Environment: Staging server [Train 83]

Steps to reproduce:

1. Go to any Create account form
2. Enter Email, password, age and go for the create account
3. Choose what to sync and accept
4. Go to mail and confirm creating account
5. Go back to firefox 

Actual result: 
The green tick sign and account verification  confirmation is not always received so you have to resend email and re-confirm, or just can't verify account
For further details please see 

Note1: This could not be reproduced on Android, only on desktop version
Note2: May be related to the excessive usage of the same email address when creating sync test accounts

Cannot reproduce on release server
I was unable to reproduce the problem outlined here, but using a variation of these STRs, I was able to find https://github.com/mozilla/fxa-content-server/issues/4873 which is most definitely a blocker.
[Tracking Requested - why for this release]:
Since this is not reproducible on android, I'm changing the fennec tracking nomination to desktop 55.
tracking-fennec: ? → -
tracking-firefox55: --- → ?
(Reporter)

Comment 3

a year ago
Hi everyone. 

We were able to reproduce this issue again while testing the 84 train, and it seems that indeed is a mailing client problem since after creating a series of new accounts (>10) by using the same mailing address (i use my gmail account mihai.ninu88+nr@gmail.com - this way all the confirmation emails are getting in the root email address and there is no need to create new emails for each account)
(Reporter)

Comment 4

a year ago
Follow up on comment 3, 

Tried creating a new account with another email client, switched to yahoo and the confirmation email is never received so i think this may also be a firefox profile issue.
Toby, can you follow up? This looks like a sync bug for desktop that has been around at least since 53 release. I am not sure when it started. 

Also, I notice this Bugzilla product/component doesn't have an triage owner. Should that be you, or someone else?
status-firefox53: affected → wontfix
tracking-firefox54: --- → +
tracking-firefox55: ? → +
Flags: needinfo?(telliott)
Shane, did you figure out the cause here? Is this still reproducible?
Flags: needinfo?(mixedpuppy)
I haven't done much with sync in years, unfortunately, so I don't know who would be the exact correct person. 

The person who would know is rkelly@mozilla.com, but when I try to needinfo him, it suggests it's not a valid user. That's very odd and probably it's own bug :)

I'll ship him email and point him here.
Flags: needinfo?(telliott)
Mark, who should I be talking to about Sync problems?
Flags: needinfo?(markh)
Flags: needinfo?(rfkelly)
I think you're looking for the other Shane.
Flags: needinfo?(mixedpuppy) → needinfo?(stomlinson)
> rkelly@mozilla.com

Heh, you need the "f" in there: rfkelly@mozilla.com :-)

It's not clear to me from the comment thread here exactly what the problem is - is it that the email itself is never received, or that clicking the link in the email does not take you to the expected screen?
Flags: needinfo?(rfkelly) → needinfo?(mihai.ninu)
(In reply to Liz Henry (:lizzard) (needinfo? me) from comment #8)
> Mark, who should I be talking to about Sync problems?

It looks like you found all the right people :) Also of note is that this is unlikely to be a client bug and more likely to be on the FxA servers (but the right people for that are also all here)
Flags: needinfo?(markh)
Removing my ni from this. Improving email deliverability is an active goal this quarter, :rfkelly has much more context than I do.
Flags: needinfo?(stomlinson)
(Reporter)

Comment 13

a year ago
Hi everyone,

This issue was a specific FxA creation on the STAGING server. Could not be reproduced on the release server (prod) and also could not be reproduced while testing the FxA train 85 release. 
And the issue was referring to the fact that the actual account confirmation was not received after confirming it in the email.
Flags: needinfo?(mihai.ninu)
> could not be reproduced while testing the FxA train 85 release

I'm going to close this out since it's not reproducible with latest FxA release, but don't hesitate to re-open if it comes up again.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
Per comment #13, mark 54/55 won't fix.
status-firefox54: affected → wontfix
status-firefox55: affected → wontfix
You need to log in before you can comment on or make changes to this bug.