Closed Bug 1352099 Opened 4 years ago Closed 4 years ago

[PWA] Web Apps don't always have a title and icon in the task switcher entry

Categories

(Firefox for Android Graveyard :: Web Apps (PWAs), defect, P1)

ARM
Android
defect

Tracking

(firefox55 verified)

VERIFIED FIXED
Firefox 55
Tracking Status
firefox55 --- verified

People

(Reporter: oana.horvath, Assigned: daleharvey)

References

Details

Attachments

(3 files)

Attached image ft - webapp task.png
Device:  LG G4 (Android 5.1) & Huawei Honor 8 (Android 6.0)
Build: Nightly 55.0a2 (2017-03-30);

Steps to reproduce:
1. Install a web app like: Financial Times (ft.com), or pokedex.org.
2. Open the web app.
3. Open the recent apps tray and check the task's title and icon.

Expected result:
Each web app should have a title & icon from the app's manifest.

Actual result:
Web apps tasks don't always have an icon and title. See screenshots attached.

notes: These two app examples initially had shown the correct icon and title, but while testing, I've found that they stopped working correctly and started showing only a generic "Web App" title and the Nightly icon. Can not determine an exact cause, I've reset Nightly and re-installed the web apps, with the same results.
Attached image pokedex- task.png
Blocks: 1285858
Priority: -- → P1
I have seen this occasionally, will investigate
Assignee: nobody → dale
I am seeing this more often when I am using multiple webapps, if I only have 1 it works fine, but if I am constantly opening new ones, possibly a probably with webappindexer and reusing activities
ok found it, the background activity is being killed and during onCreate for some reason getIntent().getStringExtra is not returning anything
Ah I can see how the saveInstanceState is being used in other activities now
I based this patch on top of https://bugzilla.mozilla.org/show_bug.cgi?id=1352726, got rid of having both loadManifest + updateFromManifest since that seemed unnecessary.
Attachment #8853739 - Flags: review?(s.kaspari)
Attachment #8853739 - Flags: review?(s.kaspari) → review+
Pushed by dharvey@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/d716fd77f2c9
Ensure manifest can be read on resume. r=sebastian
https://hg.mozilla.org/mozilla-central/rev/d716fd77f2c9
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
Verified as fixed on Nightly 55 (2017-04-05).
Devices:
- Motorola Nexus 6 (Android 7.0)
- LG G4 (Android 5.1)
- LG G4 (Android 6.0)

Note: on Huawei Honor 8 (Android 6.0), Xiaomi Mi Pad 2 (Android 5.1), Huawei MediaPad M2 (Android 5.1.1) the tasks still don't have a title and icon, just the generic "WebApp" name and the Nightly icon. These all have the EMUI system.
Status: RESOLVED → VERIFIED
(In reply to Oana Horvath from comment #9)
> Verified as fixed on Nightly 55 (2017-04-05).
> Devices:
> - Motorola Nexus 6 (Android 7.0)
> - LG G4 (Android 5.1)
> - LG G4 (Android 6.0)
> 
> Note: on Huawei Honor 8 (Android 6.0), Xiaomi Mi Pad 2 (Android 5.1), Huawei
> MediaPad M2 (Android 5.1.1) the tasks still don't have a title and icon,
> just the generic "WebApp" name and the Nightly icon. These all have the EMUI
> system.
Forgot to mention here that the web apps behave the same on Chrome on these devices: without custom icon and title. 
I will file a new bug if it's possible to solve this.
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.