[regression] from Bug 1330882; restoring window-sizes no longer works

RESOLVED WORKSFORME

Status

()

Core
XUL
RESOLVED WORKSFORME
8 months ago
8 months ago

People

(Reporter: matthias koplenig, Unassigned)

Tracking

(Blocks: 1 bug, {regression})

Trunk
x86_64
Mac OS X
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 months ago
With >privacy.resistFingerprinting = true< windows/modal-dialogs are no longer restored/opened to the correct sizes.

regressed by bug 1330882
(Reporter)

Updated

8 months ago
Blocks: 1330882

Updated

8 months ago
Duplicate of this bug: 1352305

Updated

8 months ago
Keywords: regression

Comment 2

8 months ago
We intentionally disallow session restore to restore window sizes when 'privacy.resistFingerprinting = true'. It is because of that we would enforce the window sizes to be rounded dimensions, 1000x1000 or the nearest 200x100 depends on your screen resolution, for everytime opening a new window when fingerprinting resistance is enabled. By doing this, it will decrease the entropy, and make a browser hard to be fingerprinted.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.