Status

()

Core
Networking: HTTP
RESOLVED WONTFIX
a year ago
a year ago

People

(Reporter: marina ala, Unassigned)

Tracking

52 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Created attachment 8853104 [details]
http2-usage-dia.png

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20170317040903

Steps to reproduce:

Visit any website in modern days. 


Actual results:

It used HTTP 1.1 that was designed to serve only text... time has passed. 


Expected results:

All websites should use the much more faster HTTP/2 with mandatory TLS. No plaintext, no OLD HTTP 1.1. 

Mozilla Firefox needs to take care of the health of the ecosystem of the internet. 

According to: https://w3techs.com/technologies/history_overview/site_element/all

HTTP2 usage was 6.7% at 2016 Mar 1, and 12.9% at 2017 Mar 1. 

If we create a graph from this stat: http2-usage-dia.png, we can see that ~it will reach 100% at 2031 (estimated, but we think it will be much before it because HTTP/2 is much more efficient). 

All the major/minor webservers already support HTTP/2: https://github.com/http2/http2-spec/wiki/Implementations

Proposal: Firefox should disable (kill!) all the non HTTP/2 support until 2031. 

Also useful that users should warn the website operators if they are not using the cost-efficient HTTP/2. An easy way to detect the old HTTP 1.1 usage is via a Firefox Add-on: 

https://addons.mozilla.org/en-us/firefox/addon/spdy-indicator/

Thank you.
(Reporter)

Comment 1

a year ago
Did someone noticed bugzilla.mozilla.org still uses HTTP/1.1?

Updated

a year ago
Component: Untriaged → Networking: HTTP
Product: Firefox → Core
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.