Restore intermittently failing OMTA tests: test_animations_playbackrate.html, test_animations_iterationstart.html, test_animations_effect_timing_enddelay.html

RESOLVED FIXED in Firefox 57

Status

()

enhancement
P2
normal
RESOLVED FIXED
2 years ago
11 months ago

People

(Reporter: birtles, Assigned: birtles)

Tracking

Trunk
mozilla57
Points:
---

Firefox Tracking Flags

(firefox57 fixed)

Details

Attachments

(1 attachment)

The following three tests started failing a lot recently:

  test_animations_playbackrate.html
  test_animations_iterationstart.html
  test_animations_effect_timing_enddelay.html

It appears that this started happening since bug 759252 landed.

See bug 1351038 comment 8 onwards for some analysis. It seems we fail to remove animations from the compositor (in time?) in some cases. The current suspicion is that MozAfterPaint events from the chrome document (tab bar) are somehow causing the test to think painting has finished.

These tests are failing frequently enough that we will disable them to give us time to investigate properly. This bug tracks restoring them once we have worked out the cause.
See Also: → 1351042
See Also: → 1351039
In bug 1351038 I ended up disabling test_animations_effect_timing_enddelay.html altogether (not just replacing RunsOn.Compositor with RunsOn.Either). The following log from that file, however, is particularly interesting:

  https://treeherder.mozilla.org/logviewer.html#?job_id=87808294&repo=try&lineNumber=2824

This is from a push to try with the offending test having only the s/RunsOn.Compositor/RunsOn.Either/ change made. In this log we're ticking the refresh driver and updating the compositor but we're not updating style on the main thread. I'm not sure why.
Priority: -- → P2
(In reply to Brian Birtles (:birtles, away until 19 Sep) from comment #3)
> Let's see how these tests behave now:
> https://treeherder.mozilla.org/#/
> jobs?repo=try&revision=ee4cd77c9f670e94f10be1d7f8b9927908172080

So far, so good. There are still a few jobs left to complete but assuming they're ok might try to re-enable these tests.
Comment on attachment 8905816 [details]
Bug 1352336 - Restore intermittently failing OMTA tests: test_animations_playbackrate.html, test_animations_iterationstart.html, test_animations_effect_timing_enddelay.html;

https://reviewboard.mozilla.org/r/177622/#review182682

Yay!
Attachment #8905816 - Flags: review?(hikezoe) → review+
Pushed by bbirtles@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/915065b1b334
Restore intermittently failing OMTA tests: test_animations_playbackrate.html, test_animations_iterationstart.html, test_animations_effect_timing_enddelay.html; r=hiro
https://hg.mozilla.org/mozilla-central/rev/915065b1b334
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
Assignee: nobody → bbirtles
You need to log in before you can comment on or make changes to this bug.