Closed Bug 1352394 Opened 4 years ago Closed 4 years ago

Crash in java.lang.NullPointerException: Attempt to invoke virtual method ''java.lang.String org.mozilla.gecko.Tab.getURL()'' on a null object reference at org.mozilla.gecko.webapps.WebAppActivity.onNewIntent(WebAppActivity.java)

Categories

(Firefox for Android Graveyard :: Web Apps (PWAs), defect, P1)

All
Android
defect

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: sebastian, Unassigned)

References

Details

(Keywords: crash)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-a875c6bd-ae65-496f-83b7-100bb2170331.
=============================================================

java.lang.NullPointerException: Attempt to invoke virtual method 'java.lang.String org.mozilla.gecko.Tab.getURL()' on a null object reference
	at org.mozilla.gecko.webapps.WebAppActivity.onNewIntent(WebAppActivity.java:68)
	at android.app.Instrumentation.callActivityOnNewIntent(Instrumentation.java:1223)
	at android.app.Instrumentation.callActivityOnNewIntent(Instrumentation.java:1235)
	at android.app.ActivityThread.deliverNewIntents(ActivityThread.java:2802)
	at android.app.ActivityThread.performResumeActivity(ActivityThread.java:3399)
	at android.app.ActivityThread.handleResumeActivity(ActivityThread.java:3469)
	at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:2732)
	at android.app.ActivityThread.-wrap12(ActivityThread.java)
	at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1477)
	at android.os.Handler.dispatchMessage(Handler.java:102)
	at android.os.Looper.loop(Looper.java:154)
	at android.app.ActivityThread.main(ActivityThread.java:6119)
	at java.lang.reflect.Method.invoke(Native Method)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:886)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:776)
Assignee: nobody → dale
Hmm, I cant reproduce this, do you remember how you did? testing with kill activities, from the crash stack it kinda seemed like the browser tabs had been closed in the browser then a web app launched but that still looked to work, can obviously chuck a try catch around it but would like to know the root cause first
I was going to touch that code as part of the work on bug 1351739 (or a potential follow-up) anyway, which might obviate this issue.
Somehow I lost my comment when updating Nightly.. anyhow, unfortunately I do not have any STR. I only have Twitter and Telegram as standalone web app installed.
Managed to reproduce it, it looks like I expected, close the tabs in the browser then open a running web app and it will hit this which is not a huge surprise since there is no selected tab. But I can only reproduce it on Nightly and not on a custom build which seems strange
And yeh 1351739 is going to heavily effect this, so probably best to see if this is fixed as part of it, JanH if there is anything I can do to help with that code this week happy to
Priority: -- → P1
Assignee: dale → nobody
Depends on: 1351739
(In reply to Dale Harvey (:daleharvey) from comment #5)
> And yeh 1351739 is going to heavily effect this, so probably best to see if
> this is fixed as part of it, JanH if there is anything I can do to help with
> that code this week happy to

So bug 1351749 just landed last week.
We can check the crash report and see if it still happening.
(In reply to Wesley Huang [:wesley_huang] (EPM) (NI me) from comment #6)
> (In reply to Dale Harvey (:daleharvey) from comment #5)
> > And yeh 1351739 is going to heavily effect this, so probably best to see if
> > this is fixed as part of it, JanH if there is anything I can do to help with
> > that code this week happy to
> 
TYPO: should be bug 1351739
I could previously rerpoduce this but looks fixed with JanH's work, will keep an eye open
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.