Status

()

P1
normal
RESOLVED FIXED
2 years ago
8 months ago

People

(Reporter: sdaswani, Assigned: bmunar)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [MMA] [MobileCore])

Attachments

(2 attachments)

Comment hidden (empty)
(Reporter)

Comment 1

2 years ago
Susheel to discuss with Product, Engineering and Marketing what events we are going to drop and at what granularity.
Assignee: nobody → sdaswani
Blocks: 1351446
Flags: needinfo?(sarentz)
Flags: needinfo?(bbermes)
Whiteboard: [mma]
(Reporter)

Comment 2

2 years ago
These are the events that Product / Marketing wants:

Close Private Tabs
Close Private Tabs when leaving Private Browsing
FocusInstalledState - to know if user has Focus installed or not
SavePassword
OpenLoginManager (Settings)
SaveBookmark
OpenBookmark
LoadBookmark
OpenMailToLink - When the user taps a mail link
HasAlternativeMailClient - keep flag to know if users has alternative mail app installed
Or: OpenLink with a type attribute. Then we are also ready for tel: or sms: links.
OpenTab - When a user opens a new tab
Opens the app (first run, second run, last opened)
Users who have not opened the app in x days 
Interact with search url area
Stay on a page for x period of time
Visiting a website x times 
Download videos or any other media

Log an LeanPlum event every time one of these thing happen.
Flags: needinfo?(sarentz)
Flags: needinfo?(bbermes)
(Reporter)

Updated

2 years ago
Assignee: sdaswani → bmunar
(Reporter)

Updated

2 years ago
Duplicate of this bug: 1352566
(Reporter)

Comment 4

2 years ago
Status:

Blockers:
1) We are still waiting for the Open Source SDK from LP.
2) Jean is going to figure out her thoughts around the following events:

Stay on a page for x period of time
Visiting a website x times 

https://mozilla.slack.com/archives/C4NTWRSNN/p1491847229123484?thread_ts=1491587306.607686&cid=C4NTWRSNN
(Assignee)

Comment 5

a year ago
Created attachment 8860201 [details] [review]
PR - a little gnarly and includes some previous work from this original branch
Attachment #8860201 - Flags: review?(sdaswani)
Attachment #8860201 - Flags: review?(sarentz)
Priority: -- → P2
Whiteboard: [mma] → [MMA] [MobileCore]
Iteration: --- → 1.20
Priority: P2 → P1
(Reporter)

Updated

a year ago
Attachment #8860201 - Flags: review?(sdaswani) → review+
(Reporter)

Comment 7

a year ago
https://docs.google.com/spreadsheets/d/1XLwjK7eZgDD7ncbQ2Jm37aEMRiylLekOze4u9yEXSeM/edit#gid=1499104175 is the source of truth for events required.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Updated

a year ago
Summary: Drop LeanPlum events to serve as triggers for Focus Promotion → Telemetry via Leanplum
(Reporter)

Comment 8

a year ago
Created attachment 8871481 [details] [review]
Pull Request

This PR differs from the previous version by the following:
1) Removed the custom focus promo (and all changes related to it)
2) Removed the telemetry we were recording during private browsing
3) Removed some changes not related to Leanplum
4) Removed some silly whitespace changes
5) Addressed James' comments, except for two nits.

Now it's all very clearly just about 1) integrating the LP SDK and 2) dropping some events via LP.
Attachment #8871481 - Flags: review?(sleroux)
Attachment #8871481 - Flags: review?(sarentz)
Attachment #8871481 - Flags: review?(jhugman)
Attachment #8871481 - Flags: review?(fpatel)
Attachment #8871481 - Flags: review?(sarentz) → review+
Whiteboard: [MMA] [MobileCore] → [MMA] [MobileCore][needsuplift]
(Reporter)

Comment 9

a year ago
Committed in https://github.com/mozilla-mobile/firefox-ios/pull/2711/
Status: REOPENED → RESOLVED
Last Resolved: a year agoa year ago
Resolution: --- → FIXED
Whiteboard: [MMA] [MobileCore][needsuplift] → [MMA] [MobileCore]
Attachment #8871481 - Flags: review?(sleroux)
Attachment #8871481 - Flags: review?(fpatel)
Attachment #8871481 - Flags: review?(jhugman)

Updated

8 months ago
Attachment #8860201 - Flags: review?(sarentz)
You need to log in before you can comment on or make changes to this bug.