Firefox developers disrespect large swaths of users

RESOLVED INVALID

Status

()

RESOLVED INVALID
2 years ago
a year ago

People

(Reporter: byefirefox, Unassigned)

Tracking

52 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.9) Gecko/20100101 Goanna/3.2 Firefox/45.9 PaleMoon/27.2.1
Build ID: 20170329203704

Steps to reproduce:

I innocently ran Firefox just like I do every other day.


Actual results:

Lazy Firefox developers made a unilateral decision to force Linux users to run an unnecessary resource-hogging PulseAudio server, based on nothing their own selfish interests and without factoring in the interests of much of the Linux community, many of whose whole reason for running Linux is to have the option to turn off bloated unnecessary "services" like Pulse.

And, not satisfied with just demanding a configuration update from their more prudent users, they also program a smug condescending message admonishing users who already knew exactly what they were doing and why when they disabled Pulse.


Expected results:

Firefox developers should have gone taken jobs at Microsoft or Apple, better pay and customers who don't realize how you are making their experience worse by removing choices and forcing unnecessary bloat.

Updated

2 years ago
Component: Untriaged → Audio/Video
OS: Unspecified → Linux
Product: Firefox → Core
Hardware: Unspecified → x86_64

Updated

2 years ago
Blocks: 1247056
Component: Audio/Video → Audio/Video: cubeb
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID

Comment 1

a year ago
Sorry for replying to this bug, not really my style, but all existing ALSA/Pulse bugs seem closed to comments.

Is there any update on the ALSA support in Firefox? Is the current Pulse decision final?

(I would be happy if you reply. I am kindly asking because I need this information to finalize my consideration requesting part of my donated money back from Mozilla Foundation over previous years. Thank you.)
You need to log in before you can comment on or make changes to this bug.