Enable ALSA for SeaMonkey up to 2.51 on Linux

RESOLVED FIXED in seamonkey2.51

Status

defect
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: frg, Assigned: frg)

Tracking

Trunk
seamonkey2.51
Unspecified
Linux

SeaMonkey Tracking Flags

(seamonkey2.49esr fixed, seamonkey2.50 fixed, seamonkey2.51 fixed, seamonkey2.52 wontfix)

Details

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
In Bug 1247056 ALSA support was disabled by default for Firefox. This might cause problems for SeaMonkey users. It was decided to enable it for SeaMonkey 2.49 ESR (based on Gecko ESR 52) at least. As long as support for it is in the tree and does not cause severe regressions or problems the option will also be enabled for Nightly builds.
(Assignee)

Comment 1

2 years ago
Attachment #8853749 - Flags: review?(iann_bugzilla)

Comment 2

2 years ago
Comment on attachment 8853749 [details] [diff] [review]
1352812-alsa-enable.patch

LGTM r=me
Attachment #8853749 - Flags: review?(iann_bugzilla) → review+
(Assignee)

Comment 3

2 years ago
https://hg.mozilla.org/comm-central/rev/808b3329b8adebee687424279d06abd43cec0d70
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
(Assignee)

Comment 4

2 years ago
Comment on attachment 8853749 [details] [diff] [review]
1352812-alsa-enable.patch

Better letting it ride a few days in c-c first.

[Approval Request Comment]
Regression caused by (bug #): 1247056
User impact if declined: No sould if Pulseaudio is not installed.
Testing completed (on m-c, etc.): c-c c-b
Risk to taking this patch (and alternatives if risky): none for now.
String changes made by this patch: none

comm-release only because not sure if we need a transition release to 2.49 ESR. Also approval for comm-esr52 is needed.
Attachment #8853749 - Flags: approval-comm-release?
Attachment #8853749 - Flags: approval-comm-beta?
Attachment #8853749 - Flags: approval-comm-aurora?

Comment 5

2 years ago
Comment on attachment 8853749 [details] [diff] [review]
1352812-alsa-enable.patch

a=me for all
Attachment #8853749 - Flags: approval-comm-release?
Attachment #8853749 - Flags: approval-comm-release+
Attachment #8853749 - Flags: approval-comm-beta?
Attachment #8853749 - Flags: approval-comm-beta+
Attachment #8853749 - Flags: approval-comm-aurora?
Attachment #8853749 - Flags: approval-comm-aurora+
Comment on attachment 8853749 [details] [diff] [review]
1352812-alsa-enable.patch

feedback requested on IRC by frg to me. Latest hourly was for the previous changeset and just after that, L64 builds started failing. Will have to wait. Or maybe revert the patch and see if hourlies build again.
Attachment #8853749 - Flags: feedback?(antoine.mechelynck)
(Assignee)

Comment 7

2 years ago
The search plugins patch got into m-c again. Might be this one. Need to build locally and check.
(Assignee)

Comment 8

2 years ago
Backed out. Linking webrtc tests failed:

https://hg.mozilla.org/comm-central/rev/946cd1b2cf0accade39d05993924ca31da6e06ca

ewong: are these run on release too?

+++ snip +++

/builds/slave/c-cen-t-lnx64/build/gcc/bin/../lib/gcc/x86_64-unknown-linux-gnu/4.9.4/../../../../x86_64-unknown-linux-gnu/bin/ld: /lib64/libz.so.1: no version information available (required by /builds/slave/c-cen-t-lnx64/build/gcc/bin/../lib/gcc/x86_64-unknown-linux-gnu/4.9.4/../../../../x86_64-unknown-linux-gnu/bin/ld)
../webrtc/modules/modules_audio_device/Unified_cpp_webrtc_modules0.o: In function `webrtc::AudioDeviceLinuxALSA::RecThreadProcess()':
/builds/slave/c-cen-t-lnx64/build/mozilla/media/webrtc/trunk/webrtc/modules/audio_device/linux/audio_device_alsa_linux.cc:2152: undefined reference to `LogTime(AsyncLatencyLogger::LatencyLogIndex, unsigned long, long)'
/builds/slave/c-cen-t-lnx64/build/mozilla/media/webrtc/trunk/webrtc/modules/audio_device/linux/audio_device_alsa_linux.cc:2155: undefined reference to `LogLatency(AsyncLatencyLogger::LatencyLogIndex, unsigned long, long)'
/builds/slave/c-cen-t-lnx64/build/gcc/bin/../lib/gcc/x86_64-unknown-linux-gnu/4.9.4/../../../../x86_64-unknown-linux-gnu/bin/ld: webrtc-gtest: hidden symbol `_Z7LogTimeN18AsyncLatencyLogger15LatencyLogIndexEml' isn't defined
/builds/slave/c-cen-t-lnx64/build/gcc/bin/../lib/gcc/x86_64-unknown-linux-gnu/4.9.4/../../../../x86_64-unknown-linux-gnu/bin/ld: final link failed: Bad value
collect2: error: ld returned 1 exit status
make[4]: *** [webrtc-gtest] Error 1
make[4]: Leaving directory `/builds/slave/c-cen-t-lnx64/build/objdir/media/webrtc/trunk/gtest'
make[3]: *** [media/webrtc/trunk/gtest/target] Error 2
make[3]: *** Waiting for unfinished jobs....
Status: RESOLVED → REOPENED
Flags: needinfo?(ewong)
Resolution: FIXED → ---

Comment 9

2 years ago
Trying to support things that Firefox throws out will not help us much over the long run, but will definitely hurt us as we'll need to maintain configurations they are not supporting or testing, and we don't have the developers to actually support those. For this ESR specifically it may be OK, but I urge you to not continue it after that.
(Assignee)

Comment 10

2 years ago
Don't worry. Its mostly for 2.49 ESR and as it looks has already been broken in 2.52 for tests. It should be quite safe to use because some Linux distributions still enable it. If it no longer works removal from the mozconfigs is easy. Would be folly to support it on our own with the current devs on hand in the long run.

Comment 11

2 years ago
Err, yes - 2.49 from ESR only, will keep it alive for Linux users. If it's "just" the core tests breaking, probably not much we can do about it, as long as everything still works as intended.
(In reply to Frank-Rainer Grahl from comment #8)
> Backed out. Linking webrtc tests failed:
> 
> https://hg.mozilla.org/comm-central/rev/
> 946cd1b2cf0accade39d05993924ca31da6e06ca
> 
> ewong: are these run on release too?
> 

No..  we don't run tests on release..  *however*, we do run tests on
c-* for regular debug builds.
(I wonder if that answers the question?)
Flags: needinfo?(ewong)
Comment on attachment 8853749 [details] [diff] [review]
1352812-alsa-enable.patch

I tested a single YouTube item (Mozart's Magic Flute, https://www.youtube.com/watch?v=H5rETN9GFwA ) in the following browsers:

2.52a1 (and there is video but no sound)
UA:"Mozilla/5.0 (X11; Linux x86_64; rv:55.0) Gecko/20100101 Firefox/55.0 SeaMonkey/2.52a1" 
ID:20170403003004 en-US 
c-c:0ca38f8b1d1bd4827ce4616705a1d42f2bc78833 
m-c:38894655c89e68bcd8f45d31a0d3005f2c2b53db

2.51a2 (and there are both video and sound)
UA:"Mozilla/5.0 (X11; Linux x86_64; rv:54.0) Gecko/20100101 Firefox/54.0 SeaMonkey/2.51a2" 
ID:20170403094616 en-US 
c-a:5f5ba5e17056755dc32475a79f5ba7c92b886865 
m-a:929d6fc313e63aa9775b436659c6207f7de47b6a

Pulseaudio is installed but not configured. Alsa is installed. Even during the playback, "ps -lC pulseaudio" returns no results (column headings only).
The sound device is described as follows:
82801JD/DO (ICH10 Family) HD Audio Controller
- Configured as sound card number 0
- Driver snd-hda-intel
Attachment #8853749 - Flags: feedback?(antoine.mechelynck) → feedback+
(Assignee)

Comment 15

2 years ago
https://hg.mozilla.org/releases/comm-beta/rev/7aea773b88a5cd0ae885659baf35e708891c129d
https://hg.mozilla.org/releases/comm-release/rev/86e5aeebff01f612bc4e4615fe6b076ea0bf56ce
https://hg.mozilla.org/releases/comm-esr52/rev/b967fbcdcd147dfe1cab97cc473ebd5fef3f2073

By taking the latency logging out of the ALSA driver it can be made to work in 2.52+ without changing anything else but I do not want to touch/maintain the code so 2.51 will be the latest SeaMonkey supporting also for now.
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → FIXED
Target Milestone: seamonkey2.52 → seamonkey2.51
(Assignee)

Updated

2 years ago
Summary: Enable ALSA for SeaMonkey on Linux → Enable ALSA for SeaMonkey up to 2.51 on Linux
You need to log in before you can comment on or make changes to this bug.