Support tab groups in WebExtensions

RESOLVED DUPLICATE of bug 1232178

Status

()

Toolkit
WebExtensions: Untriaged
RESOLVED DUPLICATE of bug 1232178
a year ago
9 months ago

People

(Reporter: MartijnJoosstens, Unassigned)

Tracking

54 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:54.0) Gecko/20100101 Firefox/54.0
Build ID: 20170402004002

Steps to reproduce:

Extensions that bear the functionality of tab groups, originally introduced by Panorama, are currently not supported under WebExtensions.

The core functionality of tab groups is for the user to create groups of active tabs which can be hidden(not present in the tab-bar) and the ability to swap out those groups in a window.

I've seen it suggested before that if windows could be hidden, that that could function as tab groups. The Window API could be extended to allow for windows to have a hidden state and for windows to be seamlessly replaced with one another.

But I think a more specific API would allow for more flexibility, like having multiple groups unhidden in one window or having one tab belong to multiple groups.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1232178
(Reporter)

Comment 2

a year ago
Kris Maglione [:kmag],
Bug 1232178 seems to be more about supporting the entire "Tab Groups" extension.
I made this bug focus on the actual functionality that are tab groups.
But if you insist, can bug 1232178 be reopened. The bug was closed waiting on Luís Miguel [:quicksaver] to do a report(but not in the bug report itself). This was 11 months ago and he stopped extension development. So the bug seems to be just waiting on nothing.

I would still suggest rather reopening this bug though.

Updated

9 months ago
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---

Comment 3

9 months ago
I believe (reopened) https://bugzilla.mozilla.org/show_bug.cgi?id=1232178#c8 is a good start to track and discuss about all necessary APIs for bring Tab Group into 57.
Status: REOPENED → RESOLVED
Last Resolved: a year ago9 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1232178
You need to log in before you can comment on or make changes to this bug.