Form field does not allow entry and JAWS screenreader reads varying statements when keys are pressed

RESOLVED INVALID

Status

()

P3
normal
RESOLVED INVALID
2 years ago
a year ago

People

(Reporter: Grover-QA, Unassigned)

Tracking

(Blocks: 2 bugs, {multiprocess})

55 Branch
x86_64
Windows 10
multiprocess
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: aes+)

(Reporter)

Description

2 years ago
Jaws Version:
18.0.2530

User Agent:
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:54.0) Gecko/20100101 Firefox/55.0

Steps to Reproduce:
1. Navigate to http://drive.google.com
2. Attempt to enter characters in the password field to log in.

Expected Results:
JAWS screenreader reads "star" as the user enters characters for the password
Firefox Nightly enters in valid information

Actual Results:
JAWS screenreader says different things dependent on the key entered, and characters are not entered in the form field. The following happens when Firefox Nightly is in focus on the OS:

For example, pressing the following keys in the password, JAWS screenreader reads the following:
A - "There are no radio buttons on this page."
B - "There are no buttons on this page."
C - "There are no selectable ARIA controls, list boxes, or comboboxes on this page."
D - "This is the first element of this page."
F - "There are no form fields on this page."

This works normally when e10s is turned off.

Comment 1

2 years ago
It appears that JAWS is not switching to forms mode automatically (a high-pitched blop sound when the password field gains focus is not heard). These messages are an indication that virtual cursor is still active.

Updated

a year ago
No longer blocks: 1258839
(Reporter)

Comment 2

a year ago
This issue is still reproducible with the below specs - This continues to happen whether or not e10s is enabled.

Firefox Nightly - 57.0a1 
JAWS Version - 18.0.4938
(Reporter)

Updated

a year ago
Blocks: 1351854

Updated

a year ago
Keywords: multiprocess, singleprocess
(Reporter)

Updated

a year ago
Blocks: 1363881

Updated

a year ago
Flags: needinfo?(mzehe)
I can reproduce (or similar to) this with latest Nightly and Jaws on Win 10 at https://bugzilla.mozilla.org.  Simple try to enter a bug number into the search field. It won't work.  Profiler: https://perfht.ml/2vXeCYH
(In reply to Tracy Walker [:tracy] from comment #3)
> I can reproduce (or similar to) this with latest Nightly and Jaws on Win 10
> at https://bugzilla.mozilla.org.  Simple try to enter a bug number into the
> search field. It won't work.  Profiler: https://perfht.ml/2vXeCYH

Did you enter forms input mode?

http://www.htctu.fhda.edu/trainings/manuals/tutorials/readweb/forms.htm
Flags: needinfo?(mzehe) → needinfo?(twalker)
(Reporter)

Updated

a year ago
status-firefox56: --- → affected
status-firefox57: --- → affected

Updated

a year ago
Flags: needinfo?(twalker)

Updated

a year ago
No longer blocks: 1350984

Updated

a year ago
Blocks: 1350984
Keywords: singleprocess
Marco can you close this or adjust the priority to match severity?
Flags: needinfo?(mzehe)
Priority: -- → P3

Updated

a year ago
Whiteboard: aes+
Closing as INVALID due to user error while operating JAWS. I have seen form input working fine with recent JAWS and Nightly, provided forms mode is correctly turned on first.
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(mzehe)
Resolution: --- → INVALID

Updated

a year ago
status-firefox55: affected → ---
status-firefox56: affected → ---
status-firefox57: affected → ---
You need to log in before you can comment on or make changes to this bug.