Sync UI doesn't reflect a deleted account

RESOLVED DUPLICATE of bug 999198

Status

()

Firefox for Android
Android Sync
RESOLVED DUPLICATE of bug 999198
a year ago
8 months ago

People

(Reporter: markh, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
STR:
* Enable sync on Android, shut down the device/emulator
* From some other device, delete the FxA account entirely.
* Restart Fennec.

Expected:
* Some UI to indicate the account is bad.

Actual:
* Everything appears normal - you can even hit "sync now", and although the UI doesn't change to "syncing", it doesn't reflect there's any problem with the account.

FWIW, Desktop handles this specific case by silently resetting the device if an /account/status server call indicates the account doesn't exist.
This is a dupe of https://bugzilla.mozilla.org/show_bug.cgi?id=999198.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 999198

Updated

8 months ago
Product: Android Background Services → Firefox for Android
You need to log in before you can comment on or make changes to this bug.