http request times out when application is run as a service in windows

RESOLVED WONTFIX

Status

Testing
Marionette
RESOLVED WONTFIX
a year ago
a year ago

People

(Reporter: chongenlim, Unassigned)

Tracking

52 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/57.0.2987.133 Safari/537.36

Steps to reproduce:

I have a validator that is run under a windows service. Following are the specs.

OS:
Windows 7
Selenium Version:
3.3.0
Browser:
Firefox 52.0.2
WebDriver:
Gecko 0.15.0


Actual results:

Exception:
e1 = {"The HTTP request to the remote WebDriver server for URL http://localhost:64819/session/6e11eff8-ad12-4f55-a0cb-9038a4f987ce/element timed out after 30 seconds."}

Code that causes this exception:
wait.Until(ExpectedConditions.ElementToBeClickable(by));

Stack trace:
" at OpenQA.Selenium.Remote.HttpCommandExecutor.CreateResponse(WebRequest request) in c:\Projects\webdriver\dotnet\src\webdriver\Remote\HttpCommandExecutor.cs:line 170\r\n at OpenQA.Selenium.Remote.HttpCommandExecutor.Execute(Command commandToExecute) in c:\Projects\webdriver\dotnet\src\webdriver\Remote\HttpCommandExecutor.cs:line 121\r\n at OpenQA.Selenium.Remote.DriverServiceCommandExecutor.Execute(Command commandToExecute) in c:\Projects\webdriver\dotnet\src\webdriver\Remote\DriverServiceCommandExecutor.cs:line 84\r\n at OpenQA.Selenium.Remote.RemoteWebDriver.Execute(String driverCommandToExecute, Dictionary2 parameters) in c:\\Projects\\webdriver\\dotnet\\src\\webdriver\\Remote\\RemoteWebDriver.cs:line 1102\r\n at OpenQA.Selenium.Remote.RemoteWebDriver.FindElement(String mechanism, String value) in c:\\Projects\\webdriver\\dotnet\\src\\webdriver\\Remote\\RemoteWebDriver.cs:line 1143\r\n at OpenQA.Selenium.Remote.RemoteWebDriver.FindElementByCssSelector(String cssSelector) in c:\\Projects\\webdriver\\dotnet\\src\\webdriver\\Remote\\RemoteWebDriver.cs:line 880\r\n at OpenQA.Selenium.By.<>c__DisplayClass1e.<CssSelector>b__1c(ISearchContext context) in c:\\Projects\\webdriver\\dotnet\\src\\webdriver\\By.cs:line 288\r\n at OpenQA.Selenium.By.FindElement(ISearchContext context) in c:\\Projects\\webdriver\\dotnet\\src\\webdriver\\By.cs:line 303\r\n at OpenQA.Selenium.Remote.RemoteWebDriver.FindElement(By by) in c:\\Projects\\webdriver\\dotnet\\src\\webdriver\\Remote\\RemoteWebDriver.cs:line 435\r\n at OpenQA.Selenium.Support.UI.ExpectedConditions.<>c__DisplayClass3b.<ElementToBeClickable>b__3a(IWebDriver driver) in c:\\Projects\\webdriver\\dotnet\\src\\support\\UI\\ExpectedConditions.cs:line 434\r\n at OpenQA.Selenium.Support.UI.DefaultWait1.Until[TResult](Func`2 condition) in c:\Projects\webdriver\dotnet\src\support\UI\DefaultWait{T}.cs:line 182\r\n at DailyValidator.Company.Interact(IWebDriver driver, WebDriverWait wait, String logPath, By by, String data, String log, Boolean clickTwice) in C:\Users\dummy_user\documents\visual studio 2015\Projects\DailyValidator\DailyValidator\Company.cs:line 131"


Expected results:

The application works well when run as a console application. The issue only occurs when run as a windows service.
Unforunately we don't support running it as a service. None of the other drivers do this because it leads to issues with not having a proper display manager
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.