Status

()

Core
DOM: Core & HTML
RESOLVED DUPLICATE of bug 1352348
a year ago
a year ago

People

(Reporter: augusto.wfq, Unassigned)

Tracking

52 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Created attachment 8854987 [details]
input_file_p7s.png

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20170323105023

Steps to reproduce:

We have a field for uploading files in our application, which generally works very well, but when trying to upload a file with the extension "p7s", which represents a digital signature, we had a problem. The file type is not determined by Firefox, we all have an empty string.

Steps to Reproduce
1. Create an HTML with an input file
2. Select a p7s file
3. Get the information from the selected file in the Console
4. Check the file type


Actual results:

The file type is not determined by Firefox, all we have is an empty string.


Expected results:

The file type property should contain a value representing your mime type

Comment 1

a year ago
I think your bug is a duplicate of bug 1352348 which is originally about X509 certificate.

To be sure, open http://mime.ritey.com/ and upload your p7s file to read the MIME type.
In Firefox, you should get "application/octet-stream" instead of " application/pkcs7-signature" like in Chrome.
Flags: needinfo?(augusto.wfq)
(Reporter)

Comment 2

a year ago
I tested many files with the same extension on the site and had some strange results. Some files are recognized as "application / octet-stream", others are not. Even those not recognized by the site are sent POST with Content-Type "application / octet-stream" and all, when accessed via Javascript, have the "type" property empty. Anyway, it really seems the same problem reported in Bug 1352348.
Flags: needinfo?(augusto.wfq)
(Reporter)

Comment 3

a year ago
I just tested in Ubuntu and everything seems to work as expected. The file type has been identified as "application / pkcs7-signature" (in the work I use Windows 8.1)
According to comment 2, set duplicate of bug 1352348.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1352348
You need to log in before you can comment on or make changes to this bug.