The "Firefox Account" and "Updates" icon in about:preferences look off-center

VERIFIED FIXED in Firefox 55

Status

()

defect
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: jaws, Assigned: jaws)

Tracking

55 Branch
Firefox 55
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox55+ verified)

Details

(Whiteboard: [bugday-20170426])

Attachments

(3 attachments)

Posted image Screenshot
See attachment. The left side of the yellow box should line up with the left side of all of the category icons.
Tina, can you look in to getting these icons fixed?
Flags: needinfo?(thsieh)
Flags: needinfo?(thsieh) → needinfo?(hhuang)
[Tracking Requested - why for this release]: notable visual bug with the new preferences
Firefox Account icon should be 4 hiDPI pixels to the left, and Updates should be 3 HiDPI pixels to the left.
Posted image icons.svg
Sorry for the late reply. We had an engineer help us got the icon source file that using on Preferences, and found there is a 2px margin surrounded each icon. I've added Firefox Account and Updates to the file. Please let me know if it works, thank you!
Flags: needinfo?(hhuang)
Assignee: nobody → jaws
Status: NEW → ASSIGNED

Comment 7

2 years ago
mozreview-review
Comment on attachment 8862003 [details]
Bug 1353860 - Horizontally align the 'Firefox Accounts' and 'Updates' icons with the other icons in the preferences. Also, remove references to xlink since Gecko natively supports href.

https://reviewboard.mozilla.org/r/133992/#review137322

Seems okay - though I didn't apply / test this myself.
Attachment #8862003 - Flags: review?(mconley) → review+

Comment 8

2 years ago
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b642b20709d0
Horizontally align the 'Firefox Accounts' and 'Updates' icons with the other icons in the preferences. Also, remove references to xlink since Gecko natively supports href. r=mconley

Comment 9

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/b642b20709d0
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
I have reproduced this issue on Firefox nightly according to (2017-04-05)

Fixing bug is verified on Latest Nightly--Build ID :(20170501030204),User Agent: Mozilla/5.0 (Windows NT 6.1; rv:55.0) Gecko/20100101 Firefox/55.0

Tested OS-- windows7 32bit
Whiteboard: [bugday-20170426]
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.