[selectors4] Remove "interact" flag from :focus-within tests

RESOLVED FIXED in Firefox 55

Status

()

RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: rego, Assigned: rego)

Tracking

Trunk
mozilla55
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox55 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/57.0.2987.133 Safari/537.36

Steps to reproduce:


This comes from a PR in WPT repo:
https://github.com/w3c/web-platform-tests/pull/5370

The issue is that some reference tests are marked with "interact" flag,
which causes them to be considered manual tests instead of automatic.
However they are actually run automatically with some JavaScript.

As we're cannot modify the tests in WPT repo under css/vendor-imports/,
this should be done directly on Firefox source code.
(Assignee)

Comment 1

2 years ago
This patch has been extracted from:
https://github.com/w3c/web-platform-tests/pull/5370

The problem is that the "interact" flag on these tests
causes that they are considered manual,
when they can be run automatically.

This patch removes the "interact" flag and uses "reftest-wait" class
to be sure that the test has been completed.
(Assignee)

Comment 2

2 years ago
The tests were originally introduced in bug #1176997.

This is my first attempt to upload a patch here, so please forgive me if I did something wrong. :-)
Component: Untriaged → CSS Parsing and Computation
Product: Firefox → Core
Comment on attachment 8855199 [details] [diff] [review]
[selectors4] Remove "interact" flag from :focus-within tests

r?xidorn since he reviewed the layout parts in bug 1176997
Attachment #8855199 - Flags: review?(xidorn+moz)
Comment on attachment 8855199 [details] [diff] [review]
[selectors4] Remove "interact" flag from :focus-within tests

Review of attachment 8855199 [details] [diff] [review]:
-----------------------------------------------------------------

Looks reasonable.
Attachment #8855199 - Flags: review?(xidorn+moz) → review+
Assignee: nobody → rego
Keywords: checkin-needed

Comment 5

2 years ago
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/83eeccc86bab
[selectors4] Remove "interact" flag from :focus-within tests. r=xidorn
Keywords: checkin-needed

Comment 6

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/83eeccc86bab
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
status-firefox55: --- → fixed
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
You need to log in before you can comment on or make changes to this bug.