Last Comment Bug 135414 - Mozilla LDAP Address Book integration in 3rd party products fails
: Mozilla LDAP Address Book integration in 3rd party products fails
Status: VERIFIED FIXED
:
Product: SeaMonkey
Classification: Client Software
Component: MailNews: Address Book & Contacts (show other bugs)
: Trunk
: All All
-- normal (vote)
: ---
Assigned To: John Marmion
: yulian chang
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-04 05:38 PST by John Marmion
Modified: 2004-11-22 17:25 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Small patch to achieve this (1.04 KB, patch)
2002-04-04 05:40 PST, John Marmion
no flags Details | Diff | Splinter Review
Update Patch with an explaination for this. (1.76 KB, patch)
2002-04-15 05:07 PDT, John Marmion
dmose: review+
sspitzer: superreview+
Details | Diff | Splinter Review

Description User image John Marmion 2002-04-04 05:38:43 PST
OpenOffice.org integrates with the Mozilla Address Book using both the Mozilla
Personal Address Books and the Mozilla LDAP Address Books. A recent change to
Mozilla where the RDF data source is now based on the preference name of the
Address Book source as opposed to been earlier based on the URI scheme means
that OpenOffice.org fails when the LDAP Address Book is not a preference in
Mozilla. The reason for changing the RDF data source to be based on the
preference name is a very valid one. But in order for e.g. OpenOffice.org to
intregrate with the LDAP Address Book, it would now have to update the Mozilla
Preferences File. This should not be the role of a third-party product. Instead
Mozilla should support both.
Comment 1 User image John Marmion 2002-04-04 05:40:51 PST
Created attachment 77638 [details] [diff] [review]
Small patch to achieve this
Comment 2 User image John Marmion 2002-04-05 00:11:48 PST
requested a review for this patch yesterday.

r= wanted
Comment 3 User image Dan Mosedale (:dmose) 2002-04-11 16:38:27 PDT
The patch looks ok to me, assuming you get sspitzer to sr it and he's ok with it
too.  However, I'd like to see the comments changed to explain why that code
works so that someone who's not familiar with the history of the codebase can
easily see what's going on (ie explain what mURINoQuery is likely to contain). 
Reassigning to you, since you've got checkin priviledges now.  :-)
Comment 4 User image John Marmion 2002-04-15 05:07:27 PDT
Created attachment 79239 [details] [diff] [review]
Update Patch with an explaination for this.

Thanks for the feedback Dan. I have attempted to explain this patch and put it
in context. Let me know if this is sufficient.
Comment 5 User image Dan Mosedale (:dmose) 2002-04-26 16:00:50 PDT
Comment on attachment 79239 [details] [diff] [review]
Update Patch with an explaination for this.

r=dmose@netscape.com
Comment 6 User image (not reading, please use seth@sspitzer.org instead) 2002-04-30 01:07:53 PDT
Comment on attachment 79239 [details] [diff] [review]
Update Patch with an explaination for this.

sr=sspitzer

for mozilla, CopyCharPref() should succeed, so the code path doesn't change.

thanks for adding the clear comment.

if only more of the ab was so clear.
Comment 7 User image John Marmion 2002-04-30 10:11:27 PDT
fix checked in.
Comment 8 User image Dan Mosedale (:dmose) 2002-05-02 15:12:58 PDT
John, you realize that if you need this on the 1.0 branch, there are other steps
to go through, right?
Comment 9 User image John Marmion 2002-05-07 08:38:22 PDT
Thanks Dan, I have mailed the drivers@mozilla.org and requested this patch for
inclusion into the mozilla 1.0 branch. 
Comment 10 User image John Marmion 2002-06-19 01:36:12 PDT
This fix is in the tree and the bug should have been marked resolved.
Comment 11 User image John Marmion 2002-08-20 08:00:16 PDT
Yulian, as the reporter I can confirm that this bug is fixed if you need
verification.
Comment 12 User image yulian chang 2002-09-11 12:27:53 PDT
20020910 Trunk build on WIn2K

Thank you, John!
LDAP related functionalites are working fine. Marked as Verified.

Note You need to log in before you can comment on or make changes to this bug.