Closed Bug 1354224 Opened 3 years ago Closed 3 years ago

Upgrade to Mercurial 4.1.2

Categories

(Firefox Build System :: Task Configuration, task)

task
Not set

Tracking

(Not tracked)

RESOLVED FIXED
mozilla55

People

(Reporter: gps, Assigned: gps)

References

Details

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #1350437 +++

In bug 1350437, we deployed Mercurial 4.1.1+. Now that 4.1.2 is out, let's use a proper release.
Comment on attachment 8855433 [details]
Bug 1354224 - Upgrade to Mercurial 4.1.2;

https://reviewboard.mozilla.org/r/127284/#review130024
Attachment #8855433 - Flags: review?(dustin) → review+
Pushed by gszorc@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4bfa4d528d3b
Upgrade to Mercurial 4.1.2; r=dustin
Comment on attachment 8855433 [details]
Bug 1354224 - Upgrade to Mercurial 4.1.2;

Approval Request Comment
[Feature/Bug causing the regression]: automation stability and performance
[User impact if declined]: no end-user impact. automation only
[Is this code covered by automated tests?]: yes
[Has the fix been verified in Nightly?]: yes
[Needs manual test from QE? If yes, steps to reproduce]:  no
[List of other uplifts needed for the feature/fix]: self-isolated
[Is the change risky?]: no
[Why is the change risky/not risky?]: we upgraded automation to Mercurial 4.1 over a week ago and it is working fine.
[String changes made/needed]: none

I'd like this automation-only change made on the active Firefox release repos so automation is more robust and efficient. We've been running Mercurial 4.1.1+ for over a week without any major known issues. This patch just bumps to 4.1.2, which is pretty much identical to what's been running for a week without issue. I'd like to get 4.1 out to as many corners of automation as possible because it helps performance and server scalability.
Attachment #8855433 - Flags: approval-mozilla-beta?
Attachment #8855433 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/4bfa4d528d3b
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
Comment on attachment 8855433 [details]
Bug 1354224 - Upgrade to Mercurial 4.1.2;

This helps performance and server scalability of automation. Aurora54+.
Attachment #8855433 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
I might be overly paranoid here, but I would love to hold off on this for beta until we are done with the beta 10 build (so, I'll come back and approve this tomorrow morning).
Comment on attachment 8855433 [details]
Bug 1354224 - Upgrade to Mercurial 4.1.2;

OK, let's try this on beta now.
Attachment #8855433 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Product: TaskCluster → Firefox Build System
You need to log in before you can comment on or make changes to this bug.