Closed Bug 1354238 Opened 3 years ago Closed 2 years ago

Firefox hangs when radiogroup buttons are selected with JAWS Screenreader

Categories

(Core :: Disability Access APIs, defect, P3)

55 Branch
x86_64
Windows 10
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox55 --- unaffected
firefox56 --- unaffected
firefox57 --- fix-optional

People

(Reporter: u554753, Unassigned)

References

(Blocks 2 open bugs)

Details

User Agent 
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0

Steps to Reproduce:
1. Navigate to http://www.oaa-accessibility.org/example/30/
2. Select elements from the radio group
3. Observe screenreader behavior

Expected Result:
JAWS screenreader reads the output of the radio group the user has chosen on the list.

Actual Result:
Firefox Nightly becomes unresponsive and JAWS reads out information on the selected elements 2 to 5 minutes after the element has been chosen.

This works as intended when e10s is turned off as well as when the screenreader is turned off.
No longer blocks: 1258839
This issue is still reproducible with the following specs when e10s is enabled. However, it's no longer a 2 to 5 minute wait but more of a 45 second to a minute hang.

Firefox Nightly - 57.0a1 
JAWS Version - 18.0.4938
Flags: needinfo?(jmathies)
Depends on: jaws-jank
I'll try to generate a profile and post to the parent bug.
Flags: needinfo?(jmathies)
(In reply to Grover Wimberly IV [:Grover-QA] from comment #0)
> User Agent 
> Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:55.0) Gecko/20100101
> Firefox/55.0
> 
> Steps to Reproduce:
> 1. Navigate to http://www.oaa-accessibility.org/example/30/
> 2. Select elements from the radio group
> 3. Observe screenreader behavior
> 
> Expected Result:
> JAWS screenreader reads the output of the radio group the user has chosen on
> the list.
> 
> Actual Result:
> Firefox Nightly becomes unresponsive and JAWS reads out information on the
> selected elements 2 to 5 minutes after the element has been chosen.

I'm not having any luck hitting perf issues with this test case and the latest version of jaws. 

STR:
1) Navigate to http://www.oaa-accessibility.org/example/30/
2) use the tab key to navigate down to the radio buttons in the test case
3) use up/down arrows to navigate radio buttons 

results: wfm
NI Marco for verification of STR
Flags: needinfo?(mzehe)
Priority: P1 → P3
This no longer happens anywhere, can't reproduce with current JAWS and Firefox. Closing. Feel free to reopen if you still encounter this somewhere.
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(mzehe)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.