bugzilla.mozilla.org will be intermittently unavailable on Saturday, March 24th, from 16:00 until 20:00 UTC.

[fxa][Staging 84] Sync issues on Staging - Train 84



Cloud Services
QA: General
a year ago
11 months ago


(Reporter: sorina, Unassigned)



Firefox Tracking Flags

(firefox53 affected, firefox54 affected, firefox55 affected)



(1 attachment)



a year ago
Device: Asus ZenPad 8 (Android 6.0.1), LG G4 (Android 5.1.1), Nexus 9 (Android N) Win 10, Win 7, 6Plus - fw 9.3.5
Environment: Staging server [Train 84]

Steps to reproduce:
1. Go to any Create account form;
2. Log in with the same account on different devices(Android, Win, iOS);
3. Perform some history/bookmark;
4. In Settings -> tap on Sync.

Actual results:
- On desktop: the sync is performed only after the sync button is tapped a couple of times and is delayed. The others devices is displayed on https://goo.gl/PRhdWw but only tabs from desktop is shown, the history from android is not synced.
- On Android the "Sync now" button has visual effects but the message remains the same : "Last synced: never", the what to sync options are grayed out and also are no devices displayed in "Synced devices" folder. 

Expected results:
Sync processes is done without issues or delay and the history and synced devices is displayed on all devices.

Please check the video: https://youtu.be/RMpDME5NZ-o.


a year ago
Blocks: 1353463

Comment 1

a year ago
A little help for this issue, in about:sync-log on desktop i've found a lot of failed sync logs

Here is one of them https://www.pastebin.mozilla.org/9018251
Thanks for the logs Mihai, I'm seeing a lot of NS_ERROR_UNKNOWN_HOST errors.
Pinging the staging server api.accounts.stage.mozaws.net manually does not work either (Unknown host).
I asked on IRC, the URL to use is supposed to be: https://api-accounts.stage.mozaws.net/ (dash between api and accounts)
Flags: needinfo?(sorina.florean)
> api.accounts.stage.mozaws.net

Mihai, Sorina, is it possible this URL was typo'd when configuring one or more of the devices?  This would explain the failure to sync correctly.  The correct URL is "https://api-accounts.stage.mozaws.net" (with a dash, not a dot, after "api").
Flags: needinfo?(mihai.ninu)
> Please check the video: https://youtu.be/RMpDME5NZ-o.

I don't recognize some of the UI elements in this video, what version of Fennec was this done on?

Comment 6

a year ago
Created attachment 8856377 [details]

The attached screenshot is with the changes made in about:config, before the testing was started. 

Sorry for delay here, we were out of office. (In reply to Ryan Kelly [:rfkelly] from comment #5)
> > Please check the video: https://youtu.be/RMpDME5NZ-o.
> I don't recognize some of the UI elements in this video, what version of
> Fennec was this done on?
The video was done on 53 Beta 9 with Asus ZenPad 8 (Android 6.0.1).

(In reply to Edouard Oger [:eoger] from comment #3)
> I asked on IRC, the URL to use is supposed to be:
> https://api-accounts.stage.mozaws.net/ (dash between api and accounts)
The URL seems to be the same.
Flags: needinfo?(sorina.florean)
Flags: needinfo?(mihai.ninu)

Comment 7

a year ago
Hey Guys, 

I can confirm that the log I've attached is obsolete since there was the typo on my desktop machine.
Tried today with the correct link and all I can say is that it is reproducible, the user can sign in/out/in but the synced tabs are still not displayed and also, the sync issues are still present on both Desktop and Android 

Here, you can find a new failed log https://www.pastebin.mozilla.org/9018502 (now, with the correct configuration )
The log you've attached also indicates an invalid host:

> GET request to https://sync-7-us-east-1.stage.mozaws.net/1.5/1606888/info/collections failed: [Exception... "NS_ERROR_UNKNOWN_HOST"

Can you attach android logs as well as the sync is being performed?
Flags: needinfo?(mihai.ninu)
bobm tells me that this stage server is legitimately down. Did you register a new account? Or are you re-using an old one?

Can you try creating a new account and trying again? You'll probably get assigned to a different sync staging server and things will go better.
Hey Grisha

I was using a previously created account on that server, tried it today(11.04.) on the 53.0b11 build with a newly created account on the STAGING server and the same behavior was encountered. Signed in,but the sync is not performed . Here is the logcat you required https://pastebin.mozilla.org/9018656
Flags: needinfo?(mihai.ninu)

Comment 11

11 months ago
Same issue while testing the train 85 on stage, this time only on Android, the sync action doesn't conclude.
Mihai, could you paste your token server URL, please? (The value of your `identity.sync.tokenserver.uri` pref). Are you only seeing these errors on the stage server?
Flags: needinfo?(mihai.ninu)

Comment 13

11 months ago
Hi Kit,

Yes, this happened only on the staging server.
On Android the identity.sync.tokenserver.uri was https://token.services.mozilla.com/1.0/sync/1.5. Now i've tried changing it to token.stage.mozaws.net/1.0/sync/1.5 and the same issue can be seen.
Flags: needinfo?(mihai.ninu)
Hmm, I was able to create an account and sync on stage by setting these prefs on Desktop: https://github.com/vladikoff/fxa-dev-launcher/blob/dcdaf3e4505740056aa03084af2452bc849ea934/profile.js#L34-L40 (`Weave.Service.clusterURL` shows my Sync storage node as https://sync-4-us-east-1.stage.mozaws.net/1.5/1606901/, so it looks like everything worked correctly).

I wonder if your device is talking to different FxA and Sync stacks, and if that's why you're seeing the `{"status":"invalid-credentials","errors":[{"name":"","location":"body","description":"Unauthorized"}]}` error from the token server.

I don't know what all the prefs are for Android, and how they're different from Desktop. :-( Grisha?

Comment 15

11 months ago
After further investigation seems that for Android prefs was needed one more to be changed - token - for sync to work. We change with https://token.stage.mozaws.net/1.0/sync/1.5 and now we can see synced devices on Android and tabs open but only after we logged in again.
I will close this bug since the issue is not reproducible.
Last Resolved: 11 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.