Closed Bug 1354572 Opened 7 years ago Closed 7 years ago

Update pdfjs to 1.8.170

Categories

(Firefox :: PDF Viewer, task)

task
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: tjr, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [third-party-lib-audit])

This is a (semi-)automated bug making you aware that there is an available upgrade for an embedded third-party library. You can leave this bug open, and it will be updated if a newer version of the library becomes available. If you close it as WONTFIX, please indicate if you do not wish to receive any future bugs upon new releases of the library.

pdfjs is currently at version 1.7.401 in mozilla-central, and the latest version of the library released is 1.8.170. 

I fetched the latest version of the library from https://github.com/mozilla/pdf.js/.
Why is this linked to such an ancient update bug? Also, I already have bug 1354081 on file for updating pdf.js, but it's blocked on Gecko patches that need to land.
Flags: needinfo?(tom)
(In reply to Ryan VanderMeulen [:RyanVM] from comment #1)
> Why is this linked to such an ancient update bug? 

I wanted to link it to something, and I searched for 'pdfjs' instead of 'pdf.js'.

> Also, I already have bug
> 1354081 on file for updating pdf.js, but it's blocked on Gecko patches that
> need to land.

I'll mark this as a duplicate, but should I update that bug to say "Update to 1.8.170" or leave it as-is?
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: needinfo?(tom) → needinfo?(ryanvm)
Resolution: --- → FIXED
Just leave it as-is for now. I'll update the version number after I generate the patch and get it from their build system.
Flags: needinfo?(ryanvm)
Whiteboard: [third-party-lib-audit]
Type: defect → task
No longer depends on: 1064496
You need to log in before you can comment on or make changes to this bug.