Google Sheets does not read characters from JAWS screenreader when arrow keys are pressed

RESOLVED INVALID

Status

()

Core
Disability Access APIs
RESOLVED INVALID
6 months ago
2 months ago

People

(Reporter: Grover, Unassigned)

Tracking

(Blocks: 2 bugs, {multiprocess, singleprocess})

55 Branch
x86_64
Windows 10
multiprocess, singleprocess
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox55 affected)

Details

(Reporter)

Description

6 months ago
JAWS Version:
18.0.2530

User Agent 
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0

Steps to Reproduce:
1. Navigate to drive.google.com 
2. Login with valid credentials
3. Go to an existing document and navigate to a Google Sheet
4. Use the arrow keys to navigate between the different characters on the page.

Expected Result:
JAWS screenreader reads the output of of the characters when the user presses arrow keys.

Actual Result:
It reads all of the characters as "blank"

This is reproducible in non-e10s/e10s mode.

This might be related to Bug 1073767.
(Reporter)

Comment 1

5 months ago
Also reproducible with NVDA screenreader.
Summary: Google Sheets does not read characters from JAWS screenreader when arrow keys are pressed → Google Sheets does not read characters from JAWS/NVDA screenreader when arrow keys are pressed

Updated

4 months ago
Keywords: multiprocess, singleprocess
Marco, would you mind checking this out?
Flags: needinfo?(mzehe)

Comment 3

4 months ago
I cannot reproduce. The expected behavior is that NVDA/JAWS read the whole cell including the coordinates when navigating between cells in a sheet. It does that through a live region, since the whole sheet is drawn on a canvas element and otherwise inaccessible to screen readers. NVDA definitely works as expected in current nightly builds with E10S on and off.

A possible reason this wasn't working for Grover was that Sheets didn't enable screen reader support automatically. You can check that from the Accessibility menu in Sheets.

We should test this again once we have a build of JAWS that works with E10S, but from the NVDA side of things, this is an invalid bug. :)
Flags: needinfo?(mzehe)
(Reporter)

Comment 4

2 months ago
Thanks. When the settings are changed, it works with NVDA screenreader. Changing title as needed.
Summary: Google Sheets does not read characters from JAWS/NVDA screenreader when arrow keys are pressed → Google Sheets does not read characters from JAWS screenreader when arrow keys are pressed

Updated

2 months ago
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.