Memory leak in ns4xPluginInstance::SetWindow()

VERIFIED DUPLICATE of bug 94895

Status

()

Core
Plug-ins
VERIFIED DUPLICATE of bug 94895
16 years ago
15 years ago

People

(Reporter: Peter A Jonsson, Assigned: anthonyd)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
g_malloc0 -:- libglib-1.2.so.0 0x405ca298
gtk_type_new -:- libgtk-1.2.so.0 0x40542819 
gtk_xtbin_new gtkxtbin.c:360 libgtkxtbin.so 0x4044c34d
ns4xPluginInstance::SetWindo <...> ns4xPluginInstance.cpp:973 libgkplugin.so 
0x7faf14a9 nsObjectFrame::DidReflow <...> nsObjectFrame.cpp:1484 libgklayout.so 
0x8069a9cf nsLineLayout::ReflowFrame <...> nsLineLayout.cpp:1315 libgklayout.so 
0x80692343 nsInlineFrame::ReflowInlineF <...> nsInlineFrame.cpp:725 libgklayout.so
0x8068bef5 nsInlineFrame::ReflowFrames <...> nsInlineFrame.cpp:531 libgklayout.so 
0x8068b8c3 nsInlineFrame::Reflow <...> nsInlineFrame.cpp:442 libgklayout.so 
0x8068b647 nsLineLayout::ReflowFrame <...> nsLineLayout.cpp:1088 libgklayout.so 

Code around line 973 at the time of the scan:

972 if (!mXtBin) {
973 mXtBin = gtk_xtbin_new(win, 0);
974 // Check to see if creating mXtBin failed for some reason.
975 // if it did, we can't go any further.
976 if (!mXtBin)
977 return NS_ERROR_FAILURE;
978 } 

This seems to happen several times.

Comment 1

16 years ago
assigning to Anthony for resolution
Assignee: beppe → anthonyd

Comment 2

16 years ago
Bug 94895 has a patch which fixes this.
marked it as a dup of 94895

*** This bug has been marked as a duplicate of 94895 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 3

15 years ago
mass duplicate verifications . For filtering purposes, pls use keywd
"massdupverification"

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.