[css-grid] Incorrect overflow handling in grid cell

RESOLVED DUPLICATE of bug 1348857

Status

()

defect
RESOLVED DUPLICATE of bug 1348857
2 years ago
2 years ago

People

(Reporter: ashley, Unassigned)

Tracking

({testcase})

55 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID: 20170411030208

Steps to reproduce:

See URL: https://www.scirra.com/labs/bugs/ff-grid-overflow/

This has a simple three-cell grid where:
a) the overall grid has a fixed width of 600px
b) the grid columns are 100px 1fr 100px, meaning the middle cell should be 400px
c) the middle cell has content larger than the cell and overflow: scroll


Actual results:

The middle cell is displayed at its full size with no scrolling.


Expected results:

The middle cell should be 400px wide with scrolling. This is how it works in Chrome.
Blocks: css-grid
Component: Untriaged → Layout
Product: Firefox → Core
Summary: [CSS Grid] Incorrect overflow handling in grid cell → [css-grid] Incorrect overflow handling in grid cell
Thanks for your bug report.  This is indeed a bug, which we will fix in bug 1348857.
I'm hoping to have it fixed for Firefox 54.
No longer blocks: css-grid
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Keywords: testcase
OS: Unspecified → All
Hardware: Unspecified → All
Resolution: --- → DUPLICATE
Duplicate of bug: 1348857
You need to log in before you can comment on or make changes to this bug.