pref mail.ui.display.dateformat.default ignores system date format

RESOLVED DUPLICATE of bug 1344594

Status

SeaMonkey
MailNews: Message Display
RESOLVED DUPLICATE of bug 1344594
a year ago
a year ago

People

(Reporter: K Chayka, Unassigned)

Tracking

SeaMonkey 2.52 Branch
Unspecified
All

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:55.0) Gecko/20100101 Firefox/55.0 SeaMonkey/2.52a1
Build ID: 20170404003723

Steps to reproduce:

1. System short date format set to yyyy-mm-dd hh:mm (24hour clock)
2. Set mail.ui.display.dateformat.default pref value to 2
3. View mail-news



Actual results:

The date column in the thread pane is formatted: m/d/yy, h:mm AM/PM


Expected results:

Per http://kb.mozillazine.org/Date_display_format date in the thread pane should follow system settings.

This used to work but has been broken for some months now.

Comment 1

a year ago
Probably DUP of "Bug 1344594 - System date and time formats are not respected (all platforms) from TB 54 and later".

@reporter:
What do you think?
OS: Unspecified → Windows 10
(Reporter)

Comment 2

a year ago
Bug 1351427 is addressing the larger localized date/time format issue, which manifests itself in the mail-news threadpane. So this bug 1355565 is not needed.

Comment 3

a year ago
REPRODUCIBLE with unzipped installer of official en-US SeaMonkey 2.52a1 (NT 6.1; WOW64; rv:55.0) Gecko/20100101 Firefox/55.0 Build 20170406002917  (Default Classic Theme) on German WIN7 64bit. Also see Bug 1344594 comment #8, Bug 1344594 comment #9

Due to Bug 1344594 comment #14 we should keep this one open to track fix integration to SeaMonkey.
Status: UNCONFIRMED → NEW
Depends on: 1344594
Ever confirmed: true
OS: Windows 10 → All
You can manage the SM bugs all you like, but I'd dupe this to bug 1344594 right now.
(Reporter)

Updated

a year ago
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1344594
(Reporter)

Comment 6

a year ago
Maybe I shouldn't have duped this after all ;) Is there a schedule for porting the bug 1344594 fix to all Seamonkey platforms? Linux builds are nightly or nearly so, but Win and Mac builds are not so frequent. I'm anxious for a new Win build, myself.
You need to log in before you can comment on or make changes to this bug.