Status

()

defect
RESOLVED INVALID
2 years ago
a month ago

People

(Reporter: regnetcc, Unassigned)

Tracking

({regression})

52 Branch
Points:
---

Firefox Tracking Flags

(firefox52 wontfix, firefox-esr52 wontfix, firefox53 wontfix, firefox54 wontfix, firefox55 wontfix)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Posted image 2017-04-12_2302.png
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID: 20170412030252

Steps to reproduce:

Open any iphone case product page on site www.ezyby.com.au:

EG https://www.ezyby.com.au/product/iphone-case/believe-in-unicorn/


Actual results:

The browser only shows half of the iPhone case image


Expected results:

Should be fully iPhone case image. The browser only show fully if I resize the windows, then everything will appear correctly.

The issue doesn't appear on stable FF. My brother test Nightly  on mac doesn't have issue, other browser such as Chrome, Safari are ok. 

Thank you.

Comment 1

2 years ago
Work for me in 55.0a1 (2017-04-12) (32-bit) on Win10.
(Reporter)

Comment 2

2 years ago
I records a small screen video, hope this help. Profile has been reset.

https://www.screencast.com/t/yiAqppDj

Comment 3

2 years ago
STR:
1) Load https://www.ezyby.com.au/product/iphone-case/believe-in-unicorn/ in a tab
2) Close the tab
3) Undo Close Tab
4) Repeat steps 2 to 3 a few times if need be


Regression range:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=d19cffeae1febc6d669a024340de25228e544475&tochange=24d97dc514d4b8fe608e9aee7527615c1e613606

Regressed by bug 1300659.
Blocks: 1300659
Has Regression Range: --- → yes
Has STR: --- → yes
Component: Untriaged → DOM
Flags: needinfo?(bkelly)
Keywords: regression
Product: Firefox → Core
Version: 55 Branch → 52 Branch

Updated

2 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
I'm not going to have time to look at this immediately, unfortunately.  There is clearly some weird stuff going on in this page, though.  Every time I load it (in FF or chrome) I get a FOUC.  They may be depending on same race between setTimeout() against some other work; async stylesheet load, rAF, or something.
For example, I can reproduce this behavior on chrome when the page loads in the background:

1) Open some other page in a tab in chrome.  I used http://example.com
2) Open devtools on that page and run:

  setTimeout(_ => window.location = 'https://www.ezyby.com.au/product/iphone-case/believe-in-unicorn/', 5000)

3) Before the timer fires and navigates the window switch to a different tab
4) After the first tab navigates itself switch back and observe the image is only half shown.

Some timer is racing with other work on this page and its not guaranteed to win.
Too late for 53 at this point, but let's keep this on the radar for 54+.
(Reporter)

Comment 7

2 years ago
I updated my site to avoid this bug incurred. The image was used to be dragged and moved but it is fixed position. 

I'm quite surprise that my site load a lot faster in Chrome browser while nightly a bit slower, can feel it clearly.

If you don't mind, can you please point me the direction to fix the FOUC problem as mentioned above. I appreciate all people work here. Thank you!
(In reply to Nokizilla from comment #7)
> If you don't mind, can you please point me the direction to fix the FOUC
> problem as mentioned above. I appreciate all people work here. Thank you!

I don't see the flash of unstyled content any more.  Your changes must have fixed that.  Thanks!

I'm going to mark this WONTFIX.  As I showed in comment 5 the original site had issues in other browsers and the site has since been fixed.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(bkelly)
Resolution: --- → WONTFIX
Based on Comment 8, adjusting the tracking flags to reflect the fact that status is not affected, so the release dashboard remains correct.
Component: DOM → DOM: Core & HTML
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.