Closed Bug 1355811 Opened 3 years ago Closed 3 years ago

stylo: Gecko_GetFontMetrics creates font groups off the main thread

Categories

(Core :: CSS Parsing and Computation, defect, P1)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1356103
Tracking Status
firefox55 --- affected

People

(Reporter: froydnj, Assigned: manishearth)

References

Details

As seen in https://treeherder.mozilla.org/#/jobs?repo=try&revision=b10fecf7e5767cd076086ef3e35129341f3c1b2c:

INFO - Hit MOZ_CRASH(gfxUserFontSet not thread-safe) at /home/worker/workspace/build/src/gfx/thebes/gfxUserFontSet.h:178
INFO - #01: gfxFontGroup::gfxFontGroup [gfx/thebes/gfxTextRun.cpp:1713]
INFO - 
INFO - #02: gfxPlatformGtk::CreateFontGroup [gfx/thebes/gfxPlatformGtk.cpp:281]
INFO - 
INFO - #03: nsFontMetrics::nsFontMetrics [mfbt/RefPtr.h:53]
INFO - 
INFO - #04: nsFontCache::GetMetricsFor [mfbt/RefPtr.h:110]
INFO - 
INFO - #05: nsDeviceContext::GetMetricsFor [gfx/src/nsDeviceContext.cpp:226]
INFO - 
INFO - #06: nsRuleNode::GetMetricsFor [layout/style/nsRuleNode.cpp:391]
INFO - 
INFO - #07: Gecko_GetFontMetrics [mfbt/RefPtr.h:129]
INFO - 
INFO - #08: style::gecko::wrapper::{{impl}}::query [servo/components/style/gecko/wrapper.rs:479]
INFO - 
INFO - #09: style::values::specified::length::{{impl}}::to_computed_value::query_font_metrics [servo/components/style/values/specified/length.rs:81]
INFO - 
INFO - #10: style::values::specified::length::FontRelativeLength::to_computed_value [servo/components/style/values/specified/length.rs:94]

More font thread-safety issues.
Blocks: 1318187
Depends on: 1356103
Assignee: nobody → manishearth
Priority: -- → P1
Summary: stylo: parallel traversal creates font groups off the main thread → stylo: Gecko_GetFontMetrics creates font groups off the main thread
Being fixed in bug 1356103
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1356103
You need to log in before you can comment on or make changes to this bug.