Closed Bug 1355813 Opened 3 years ago Closed 3 years ago

stylo: Gecko_GetFontMetrics touches weak pointers on multiple threads

Categories

(Core :: CSS Parsing and Computation, defect, P1)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1356103
Tracking Status
firefox55 --- affected

People

(Reporter: froydnj, Assigned: manishearth)

References

Details

As seen in https://treeherder.mozilla.org/#/jobs?repo=try&revision=b10fecf7e5767cd076086ef3e35129341f3c1b2c :

INFO - Assertion failure: _empty || _owningThread == std::this_thread::get_id() (WeakPtr used on multiple threads), at /home/worker/workspace/build/src/obj-firefox/dist/include/mozilla/WeakPtr.h:157
INFO - #01: gfxFontconfigFontEntry::UnscaledFontCache::Lookup [gfx/thebes/gfxFcPlatformFontList.cpp:818]
INFO - 
INFO - #02: gfxFontconfigFontEntry::CreateFontInstance [mfbt/AlreadyAddRefed.h:124]
INFO - 
INFO - #03: gfxFontEntry::FindOrMakeFont [gfx/thebes/gfxFontEntry.cpp:287]
INFO - 
INFO - #04: gfxFontGroup::GetFontAt [gfx/thebes/gfxTextRun.cpp:1853]
INFO - 
INFO - #05: gfxFontGroup::GetFirstValidFont [gfx/thebes/gfxTextRun.cpp:2030]
INFO - 
INFO - #06: nsFontMetrics::GetMetrics [gfx/thebes/gfxFont.h:1551]
INFO - 
INFO - #07: nsFontMetrics::XHeight [gfx/src/nsFontMetrics.cpp:175]
INFO - 
INFO - #08: Gecko_GetFontMetrics [layout/style/ServoBindings.cpp:1678]
INFO - 
INFO - #09: style::gecko::wrapper::{{impl}}::query [servo/components/style/gecko/wrapper.rs:479]
INFO - 
INFO - #10: style::values::specified::length::{{impl}}::to_computed_value::query_font_metrics [servo/components/style/values/specified/length.rs:81]
INFO - 
INFO - #11: style::values::specified::length::FontRelativeLength::to_computed_value [servo/components/style/values/specified/length.rs:106]
INFO - 
INFO - #12: style::values::computed::length::{{impl}}::to_computed_value [servo/components/style/values/computed/length.rs:27]
INFO - 
INFO - #13: style::values::computed::length::{{impl}}::to_computed_value [servo/components/style/values/computed/length.rs:325]

More font threadsafety issues.
Blocks: 1318187
Depends on: 1356103
Assignee: nobody → manishearth
Priority: -- → P1
Summary: stylo: parallel traversal touches weak pointers on multiple threads → stylo: Gecko_GetFontMetrics touches weak pointers on multiple threads
Being fixed in bug 1356103
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1356103
You need to log in before you can comment on or make changes to this bug.