Closed Bug 1356549 Opened 3 years ago Closed 3 years ago

Custom Tab:: forms are not focused

Categories

(Firefox for Android :: General, defect, P1)

55 Branch
ARM
Android
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox55 --- affected

People

(Reporter: sflorean, Unassigned)

References

(Blocks 1 open bug)

Details

Environment: 
Device: HTC (Android 7.0), Huawei MediaPad M2 (Android 5.1.1);
Build: Nightly 55.0a1 (2017-04-14);

Steps to reproduce:
1. Launch CustomTabsActivity opening the link https://goo.gl/c7sP0s;
2. Tap on last field;
3. Type some text.

Expected result:
The field tapped is focused and user can insert/write characters.

Actual result:
The field is not focused and is overlapped with the keyboard.

Notes:
Please check the video: https://youtu.be/iVkLUj7BQ2c.
Somehow this link no longer works.
BTW, Jim, from the video is looks like a platform issue. Mind to take a look?
Flags: needinfo?(sorina.florean)
Flags: needinfo?(nchen)
Seems like the field _is_ focused right? Because you can still type in it; only it's covered by the keyboard.

I think we should set whatever flag that tells Android to resize our window when the keyboard displays, rather than have the keyboard show on top of the window.
Flags: needinfo?(nchen)
Setting P1 for the usability.
Priority: -- → P1
as per testing by Julian and myself, on Nexus5 and Pixel XL respectively, couldn't reproduce.
Could you try reproduce again?
Flags: needinfo?(sorina.florean)
Hi, tested and couldn't reproduce on latest Nightly. The form is focused, not covered by keyboard and I can see what I type. Device: Nexus 6 (Android 7.0.) and Huawei Honor (Android 5.1.1).
Flags: needinfo?(sorina.florean)
yes. I think it's somehow fixed by other patches.
we can resolve worksforme now?
Yes, I will close this bug as worksforme, since the issue is not reproducible.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.