3% Windows Heap Unclassified summary on Autoland; April 14th

RESOLVED FIXED

Status

()

Core
Graphics
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: jmaher, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
== Change summary for alert #6033 (as of April 14 2017 03:36 UTC) ==

Regressions:

  3%  Heap Unclassified summary windows10-64-vm opt      43296010.33 -> 44444610.02
  2%  Heap Unclassified summary windows7-32-vm opt       37888443.35 -> 38686192.24

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=6033

this is from this push:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=b35ed06f2e85673309258be83984b0c2939c6847&tochange=2e59e89efef982bee73573f6861f50574bab6b84

We are still new to sheriffing AWSY regressions, there is not official policy in place for AWSY- but these tests are showing a sustained regression and offer a superior measure of memory than that of Talos.
(Reporter)

Comment 1

a year ago
:milan, I see you authored this patch, can you take a look at this?
Flags: needinfo?(milan)
This looks like a regression due to a new process, which makes sense. Here's the relevant part of the diff:

> GPU (pid NNN)
> Explicit Allocations
> 
> 2.72 MB (100.0%) -- explicit
> ├──1.55 MB (57.03%) -- heap-overhead
> │  ├──0.82 MB (30.13%) ── page-cache [+]
> │  ├──0.68 MB (25.04%) ── bin-unused [+]
> │  └──0.05 MB (01.86%) ── bookkeeping [+]
> ├──0.59 MB (21.57%) ── heap-unclassified
> ├──0.21 MB (07.87%) ── profiler/profiler-state
> ├──0.14 MB (05.05%) -- xpcom
> │  ├──0.13 MB (04.66%) ── component-manager [+]
> │  └──0.01 MB (00.39%) ── category-manager [+]
> ├──0.13 MB (04.60%) -- atom-tables
> │  ├──0.13 MB (04.59%) ── main [+]
> │  └──0.00 MB (00.01%) ── static [+]
> └──0.11 MB (03.88%) ── telemetry [+]

What's interesting is that the GPU process sticks around after we close all tabs, navigate to about:blank, wait 30 seconds and force a GC.
The GPU process outlives content tabs, so that'd be why. It composites for the browser process as well.
We backed out bug 1356448, but not for the reason of this report.
Flags: needinfo?(milan)
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.