26ms uninterruptible reflow at _adjustContainerHeight@chrome://browser/content/customizableui/panelUI.xml:382:15

RESOLVED DUPLICATE of bug 1009116

Status

()

Firefox
Menus
P3
normal
RESOLVED DUPLICATE of bug 1009116
10 months ago
8 months ago

People

(Reporter: mconley, Unassigned)

Tracking

(Blocks: 2 bugs)

unspecified
Points:
---
Dependency tree / graph
Bug Flags:
qe-verify -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [ohnoreflow][qf:p2])

Here's the stack:

_adjustContainerHeight@chrome://browser/content/customizableui/panelUI.xml:382:15
_syncContainerWithMainView@chrome://browser/content/customizableui/panelUI.xml:413:13

Updated

10 months ago
Flags: qe-verify?
Priority: -- → P2
Whiteboard: [ohnoreflow][qf][photon-performance] → [ohnoreflow][qf:p1][photon-performance]
The initial attempt to solve this was bug 1252224, right? If this helps with janky doorhangers we should try to investigate the test failure that caused the backout and see if we can make it stick this time.
Blocks: 1252224

Updated

10 months ago
See Also: → bug 1358446
Another stack:

_adjustContainerHeight@chrome://browser/content/customizableui/panelUI.xml:390:15
_syncContainerWithMainView@chrome://browser/content/customizableui/panelUI.xml:421:13
MutationCallback*panelmultiview_XBL_Constructor@chrome://browser/content/customizableui/panelUI.xml:115:11
And another stack:

	

_adjustContainerHeight@resource://app/modules/PanelMultiView.jsm:373:9
_syncContainerWithMainView@resource://app/modules/PanelMultiView.jsm:402:7
handleEvent@resource://app/modules/PanelMultiView.jsm:326:9
openPopup@chrome://global/content/bindings/popup.xml:53:15
show/</<@chrome://browser/content/customizableui/panelUI.js:193:9
process@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:922:23
walkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:806:7
Promise*scheduleWalkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:739:11
schedulePromise@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:770:7
completePromise@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:707:7
TaskImpl_run@resource://gre/modules/Task.jsm:324:15
promise callback*TaskImpl_handleResultValue@resource://gre/modules/Task.jsm:396:7
TaskImpl_run@resource://gre/modules/Task.jsm:327:15
TaskImpl@resource://gre/modules/Task.jsm:277:3
asyncFunction@resource://gre/modules/Task.jsm:252:14
Task_spawn@resource://gre/modules/Task.jsm:166:12
ensureReady@chrome://browser/content/customizableui/panelUI.js:363:26
show/<@chrome://browser/content/customizableui/panelUI.js:167:7
Promise@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:390:5
show@chrome://browser/content/customizableui/panelUI.js:166:12
toggle@chrome://browser/content/customizableui/panelUI.js:151:7
handleEvent@chrome://browser/content/customizableui/panelUI.js:316:11
EventListener.handleEvent*init@chrome://browser/content/customizableui/panelUI.js:62:5
_delayedStartup@chrome://browser/content/browser.js:1396:5
EventListener.handleEvent*onLoad@chrome://browser/content/browser.js:1239:5
onload@chrome://browser/content/browser.xul:1:1
No longer blocks: 1348289

Updated

9 months ago
Flags: qe-verify? → qe-verify-

Updated

9 months ago
Priority: P2 → P3
Whiteboard: [ohnoreflow][qf:p1][photon-performance] → [ohnoreflow][qf:p1][reserve-photon-performance]
Whiteboard: [ohnoreflow][qf:p1][reserve-photon-performance] → [ohnoreflow][qf:p2][reserve-photon-performance]

Comment 4

8 months ago
The function this profile referred to does not exist anymore as of bug 1009116.

We still use sync reflows in the non-Photon code paths, but those would have different profiles.
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1009116

Updated

8 months ago
Whiteboard: [ohnoreflow][qf:p2][reserve-photon-performance] → [ohnoreflow][qf:p2]
You need to log in before you can comment on or make changes to this bug.