Assert in nsHTMLValue::GetPixelValue when reading message

VERIFIED DUPLICATE of bug 13206

Status

MailNews Core
MIME
P3
major
VERIFIED DUPLICATE of bug 13206
19 years ago
10 years ago

People

(Reporter: Phil Peterson, Assigned: jefft)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
I get this assert every time I read a message in mail/news. I don't know
if it's a problem with the XUL we generate, or with boxes, or what. cc'ing
evaughan just in case.

NTDLL! 77f7629c()
nsDebug::Assertion(const char * 0x60a50de0
??_C@_0BC@HKFM@not?5a?5pixel?5value?$AA@, const char * 0x60a50df4
??_C@_0BL@OELE@?$CImUnit?5?$DN?$DN?5eHTMLUnit_Pixel?$CJ?$AA@, const char *
0x60a50e10 ??_C@_0BO@JDGB@?4?4?2?4?4?2style?2src?2nsHTMLValue?4h?$AA@, int
0x00000068) line 181 + 13 bytes
nsHTMLValue::GetPixelValue() line 104 + 34 bytes

nsBoxFrame::GetRedefinedMinPrefMax(nsIPresContext & {...}, nsIFrame *
0x02d84110, nsCalculatedBoxInfo & {...}) line 285 + 15 bytes

nsBoxFrame::GetChildBoxInfo(nsIPresContext & {...}, const nsHTMLReflowState &
{...}, nsIFrame * 0x02d84110, nsCalculatedBoxInfo & {...}) line 333

nsBoxFrame::GetBoxInfo(nsBoxFrame * const 0x02473cb0, nsIPresContext & {...},
const nsHTMLReflowState & {...}, nsBoxInfo & {...}) line 1466 + 44 bytes

nsBoxFrame::Reflow(nsBoxFrame * const 0x02473c74, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int &
0x00000000) line 481
nsContainerFrame::ReflowChild(nsIFrame * 0x02473c70,
nsIPresContext & {...}, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState &
{...}, unsigned int & 0x00000000) line 439 + 28 bytes

RootFrame::Reflow(RootFrame * const 0x02d62c64, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int &
0x00000000) line 330
nsContainerFrame::ReflowChild(nsIFrame * 0x02d62c60,
nsIPresContext & {...}, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState &
{...}, unsigned int & 0x00000000) line 439 + 28 bytes

ViewportFrame::Reflow(ViewportFrame * const 0x02d5de14, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int &
0x00000000) line 516
PresShell::InitialReflow(PresShell * const 0x01fdc1a0, int
0x00001d97, int 0x000012b1) line 854
XULDocumentImpl::StartLayout() line 4207

XULDocumentImpl::EndLoad(XULDocumentImpl * const 0x02d2be70) line 2088

XULContentSinkImpl::DidBuildModel(XULContentSinkImpl * const 0x02d2b8a0, int
0x00000001) line 543
CWellFormedDTD::DidBuildModel(CWellFormedDTD * const
0x01fdbb10, unsigned int 0x00000000, int 0x00000001, nsIParser * 0x02d2b3c0,
nsIContentSink * 0x02d2b8a0) line 287 + 20 bytes

nsParser::DidBuildModel(unsigned int 0x00000000) line 526 + 55 bytes

nsParser::ResumeParse(nsIDTD * 0x00000000, int 0x00000000) line 894

nsParser::EnableParser(int 0x00000001) line 620 + 15 bytes

XULContentSinkImpl::DoneLoadingScript(nsIUnicharStreamLoader * 0x02d2a8d0,
nsString & {...}, void * 0x02d2b8a0, unsigned int 0x00000000) line 1647

nsUnicharStreamLoader::OnStopRequest(nsUnicharStreamLoader * const 0x02d2a8d4,
nsIChannel * 0x02d3f0c0, nsISupports * 0x00000000, unsigned int 0x00000000,
const unsigned short * 0x00000000) line 159 + 31 bytes

nsChannelListener::OnStopRequest(nsChannelListener * const 0x022b2030,
nsIChannel * 0x02d3f0c0, nsISupports * 0x00000000, unsigned int 0x00000000,
const unsigned short * 0x00000000) line 2257 + 42 bytes

nsFileChannel::OnStopRequest(nsFileChannel * const 0x02d3f0cc, nsIChannel *
0x02d3f0c0, nsISupports * 0x00000000, unsigned int 0x00000000, const unsigned
short * 0x00000000) line 835 + 42 bytes

nsOnStopRequestEvent::HandleEvent(nsOnStopRequestEvent * const 0x022b5560) line
269
nsStreamListenerEvent::HandlePLEvent(PLEvent * 0x022b5564) line 144 + 12
bytes
PL_HandleEvent(PLEvent * 0x022b5564) line 509 + 10 bytes

PL_ProcessPendingEvents(PLEventQueue * 0x00993f50) line 470 + 9 bytes

_md_EventReceiverProc(HWND__ * 0x76b60086, unsigned int 0x0000c0e5, unsigned int
 0x00000000, long 0x00993f50) line 938 + 9 bytes
USER32! 77e71820()
00993f50()
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 1

19 years ago
*** This bug has been marked as a duplicate of 13206 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 2

19 years ago
verified as duplicate.  Assertion mentioned in other bug is the same as this
one.  Other bug is still open.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.