Closed Bug 1357437 Opened 3 years ago Closed 2 years ago

Crash in mozilla::dom::workers::serviceWorkerScriptCache::`anonymous namespace''::CompareNetwork::Initialize

Categories

(Core :: DOM: Service Workers, defect, critical)

55 Branch
x86
All
defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla55
Tracking Status
firefox-esr52 --- unaffected
firefox54 --- unaffected
firefox55 --- fixed

People

(Reporter: marcia, Assigned: bhsu)

References

(Blocks 1 open bug)

Details

(Keywords: crash, topcrash)

Crash Data

Attachments

(2 files, 1 obsolete file)

This bug was filed from the Socorro interface and is 
report bp-06c8aaaa-f784-4bc4-b888-417700170418.
=============================================================

Seen while looking at crash stats - crashes started using 20170418030220: http://bit.ly/2nZDP1Z


Possible regression range based on Build ID: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c697e756f738ce37abc56f31bfbc48f55625d617&tochange=bb38d935d699e0529f9e0bb35578d381026415c4

Bug 1290951? ni on :HoPang
Flags: needinfo?(bhsu)
Hi, I'm the user from the crash report mentioned in the description. I always crash at https://www.uol.com.br/, either while loading or reloading the page. Started happening in the latest Nightly (18-04-2017). Nobody else on Mozillazine can reproduce, unfortunately.
(In reply to Guilherme Lima from comment #1)
> Hi, I'm the user from the crash report mentioned in the description. I
> always crash at https://www.uol.com.br/, either while loading or reloading
> the page. Started happening in the latest Nightly (18-04-2017). Nobody else
> on Mozillazine can reproduce, unfortunately.

Hello Guilherme - Can you paste the information from about:support? It appears the crash is only happening on Mac, and I cannot reproduce it on my machine.
Attached file aboutSupport.txt
I can reproduce this every time on Windows 10 with the latest Nightly (18-04-2017) at https://www.faceit.com/.
This my crash sig: https://crash-stats.mozilla.com/report/index/08d0c724-0767-41c1-964f-385f10170419
Looks as if Comment 2 was incorrect - I don't see any mac crashes. It looks as if from the two comments some people are easily able to repro.
Attached patch QFIX (obsolete) — Splinter Review
Assignee: nobody → bhsu
Status: NEW → ASSIGNED
Thank you all!

Those information does help a lot. Do you mind applying the QFIX and testing those site again? With those patches, I can no longer reproduce them with refreshing the pages (or loading when there already a service worker). I'll polish the patch if it works.
Flags: needinfo?(bhsu)
The signature "mozilla::dom::workers::serviceWorkerScriptCache::(anonymous namespace)::CompareManager::FetchScript" appears only on OSX and "CompareManager::FetchScript" appears only on Linux.
The signature "mozilla::dom::workers::serviceWorkerScriptCache::`anonymous namespace''::CompareNetwork::Initialize" is #4 on topcrash (for content process).
Crash Signature: [@ mozilla::dom::workers::serviceWorkerScriptCache::`anonymous namespace''::CompareNetwork::Initialize] → [@ mozilla::dom::workers::serviceWorkerScriptCache::`anonymous namespace''::CompareNetwork::Initialize] [@ mozilla::dom::workers::serviceWorkerScriptCache::(anonymous namespace)::CompareManager::FetchScript ] [@ CompareManager::FetchScript ]
Keywords: topcrash
OS: Windows 7 → All
Attachment #8859417 - Attachment is obsolete: true
Hi all, and sorry for my carelessness.

This crash is caused by lacking an appropriate error handling when fetching a script to compare. Though I think the patch provided can fix this crash, however, I think we should back out the code at this moment, since I need some more time to check it all over again.
bug 1290951 was backed out now
Crash Signature: [@ mozilla::dom::workers::serviceWorkerScriptCache::`anonymous namespace''::CompareNetwork::Initialize] [@ mozilla::dom::workers::serviceWorkerScriptCache::(anonymous namespace)::CompareManager::FetchScript ] [@ CompareManager::FetchScript ] → [@ mozilla::dom::workers::serviceWorkerScriptCache::`anonymous namespace''::CompareNetwork::Initialize] [@ mozilla::dom::workers::serviceWorkerScriptCache::(anonymous namespace)::CompareManager::FetchScript ] [@ CompareManager::FetchScript ] [@ Compare…
For me uol.com.br does not cause a crash, but https://plus.google.com/ does immediately with this signature, see https://crash-stats.mozilla.com/report/index/528dd160-be31-49f4-b165-e2b7e0170511
Does not crash anymore.
For me only was the nightly from my crash report above.
As bug 1290951 was backed out from 55, anything else we need to do in this bug or can we close this?
Flags: needinfo?(bhsu)
Sorry for the late, since bug 1290951 is going to reland again, I personally think that we should keep this bug alive for a little bit longer, in case there is anything going buggy. However, I don't have a strong preference here.
Flags: needinfo?(bhsu)
(In reply to Ben Hsu [:HoPang] from comment #16)
> Sorry for the late, since bug 1290951 is going to reland again, I personally
> think that we should keep this bug alive for a little bit longer, in case
> there is anything going buggy. However, I don't have a strong preference
> here.

Sure for keeping this open for monitoring the relanding on 56. And that sounds to me that there's no action we currently consider to take for beta 55. I changed the firefox55-status to "fixed" as after bug 1290951 was backed out from 55, crash then stopped.  :HoPang, let me know if I misunderstood anything.
The crash stopped after bug 1290951 was backed out then reland. Going to close this.
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
You need to log in before you can comment on or make changes to this bug.