Closed Bug 1357438 Opened 4 years ago Closed 4 years ago

Web apps - Login autocomplete isn't working

Categories

(Firefox for Android Graveyard :: Web Apps (PWAs), defect, P1)

55 Branch
ARM
Android
defect

Tracking

(firefox55 verified)

VERIFIED FIXED
Firefox 55
Tracking Status
firefox55 --- verified

People

(Reporter: oana.horvath, Assigned: daleharvey)

References

Details

Attachments

(1 file)

Device: LG G4 (Android 6);
Build: Nightly 55.0a1 (2017-04-18);

Steps to reproduce:
1. Go to twitter.com web app and log in.
2. Save the password.
3. Log out and go back to the login page.
4. Tap the username field for autocomplete options.

Expected result:
Username & password should be auto-filled in if it was saved. If there are multiple logins saved, a drop-down should display the options.

Actual result:
The autocomplete feature is not working.
Blocks: 1285858
To me it's an essential function not working. Flagging P1.
Priority: -- → P1
Actually, today I've investigated further and seen that not all devices have this problem.

On all these, the autocomplete works on twitter:
-Huawei MediaPad M2 (Android 5.1.1)
-Motorola Nexus 6 (Android 7.0)
-Asus ZenPad 8.0 Z380KL (Android 6.0.1)

Not working on:
- LG G4 (Android 5.1)
- LG G4 (Android 6.0)
*on these, the autocomplete works in the browser.
let's revisit the priority once we have further info after investigation.
There was a thing I was missing in the first place. The issue is reproducible on any device and other web apps too, e.g. datememe.com, as it follows:
- when there is just one login saved, the autocomplete works: username and pass are auto-filled in when you start the web app.
- when there are 2 or more logins saved for the same site, passwords are filled in but usernames not. You have to type in the username and then the password will be autocompleted. In the browser, there is a username drop-down list for auto-complete that doesn't appear in the web app.
Apologies for the previous incomplete report.
Assignee: nobody → dale
Ok found whats happening here although a little confused, In standalone mode FormAssistPopup is not being constructed. 

As far as I can tell http://searchfox.org/mozilla-central/source/mobile/android/base/java/org/mozilla/gecko/GeckoApp.java#1654 is the only place where it gets created, however this code is being hit inside standalone mode, also when inside the browser mode this code gets hit after FormAssistPopup constructor is called, so not certain where this is getting created
This should fix autocomplete (login) for both webapps and custom tabs
Attachment #8864826 - Flags: review?(walkingice0204)
By should I mean it does, I tested webapps at least
Attachment #8864826 - Flags: review?(walkingice0204) → review+
Pushed by dharvey@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/e472f16bdd17
Add form assist popup to custom tabs / webapps. r=walkingice
https://hg.mozilla.org/mozilla-central/rev/e472f16bdd17
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
Verified the login autocomplete on web apps in Nightly 55.0a1 (207-05-17).
Devices:
-LG G4 (Android 6)
-Huawei Honor 5X (Android 5.1.1)
Status: RESOLVED → VERIFIED
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.