Crash in ShareTo PlugInKit: [PKService run] + 848 / 0xdead10cc

VERIFIED FIXED

Status

()

VERIFIED FIXED
a year ago
a year ago

People

(Reporter: st3fan, Assigned: st3fan)

Tracking

unspecified
Other
iOS

Firefox Tracking Flags

(fxios-v7.0 affected, fxios-v7.1 affected, fxios-v7.2 affected, fxios-v7.3 verified, fxios7.3, fxios-v8.0 verified)

Details

(Whiteboard: [MobileCore])

Attachments

(1 attachment)

(Assignee)

Description

a year ago
This is the same problem as described in bug 1350861
(Assignee)

Comment 1

a year ago
Created attachment 8859276 [details] [review]
PR https://github.com/mozilla-mobile/firefox-ios/pull/2638

This patch makes sure that we do not leave the *Profile* open when the *ShareTo* app extension goes into the background. It does this by removing the *Profile* as an instance variable and limit the scope where it is used (opened, used, closed) to absolute minimum.
Attachment #8859276 - Flags: review?(jdarcangelo)
(Assignee)

Comment 3

a year ago
Steps to reproduce the crash:

1) Install v7.x
2) Open Safari
3) Share the current URL to Firefox with the ShareTo extension (bookmarks or readinglist)
4) Immediately open the share extension again, but do not share, leave open
5) Lock device
6) Wait a minute
7) Unlock device

Expected: Share extension is still there.

Actual: Share extension has been killed by the OS. You can find a crash log for ShareTo that looks like this:

Exception Type:  EXC_CRASH (SIGKILL)
Exception Codes: 0x0000000000000000, 0x0000000000000000
Exception Note:  EXC_CORPSE_NOTIFY
Termination Reason: Namespace SPRINGBOARD, Code 0xdead10cc
Triggered by Thread:  0
(Assignee)

Updated

a year ago
Assignee: nobody → sarentz
(Assignee)

Updated

a year ago
Status: NEW → ASSIGNED
Able to reproduce both SendTo and ShareTo crashes on latest master. Stefan, do we need a separate bug for SendTo?
(Assignee)

Updated

a year ago
Iteration: --- → 1.20
(Assignee)

Updated

a year ago
Whiteboard: [MobileCore]
(Assignee)

Updated

a year ago
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
Unable to reproduce the crash on v7.3b2756. 

v8.0 is still affected so this patch needs to land there also.
status-fxios-v7.3: --- → fixed
status-fxios-v8.0: --- → affected
(Assignee)

Comment 6

a year ago
The followup fix for this bug landed a couple of hours after the previous comment. Catalin, can you give this a try again on master?
Flags: needinfo?(catalin.suciu)
The crash is no longer reproducible on master. Tested on f9f4cf1ba.
Status: RESOLVED → VERIFIED
status-fxios-v7.3: fixed → verified
status-fxios-v8.0: affected → verified
Flags: needinfo?(catalin.suciu)
You need to log in before you can comment on or make changes to this bug.