Enabling a System Add-on with a WebExtension causes browser_tabopen_reflows.js to fail with `unexpected uninterruptible reflow`

RESOLVED DUPLICATE of bug 1358415

Status

defect
P1
normal
RESOLVED DUPLICATE of bug 1358415
2 years ago
11 months ago

People

(Reporter: standard8, Assigned: kmag)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: triaged)

Reporter

Description

2 years ago
In bug 1355569, we are looking to enable Screenshots during unit test runs. On try we're hitting this error:

https://treeherder.mozilla.org/logviewer.html#?job_id=92425763&repo=try&lineNumber=3933

1INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/general/browser_tabopen_reflows.js | unexpected uninterruptible reflow '<stack>' - 
INFO - Stack trace:
INFO -     chrome://mochitests/content/browser/browser/base/content/test/general/browser_tabopen_reflows.js:reflow:136
INFO -     chrome://browser/content/ext-utils.js:get width:528
INFO -     resource://gre/modules/ExtensionTabs.jsm:convert:470
INFO -     chrome://browser/content/ext-tabs.js:fireForTab:239
INFO -     chrome://browser/content/ext-tabs.js:statusListener:283
INFO -     resource://gre/modules/ExtensionTabs.jsm:onStateChange:1116
INFO -     chrome://browser/content/tabbrowser.xml:callListeners:492
INFO -     chrome://browser/content/tabbrowser.xml:_callProgressListeners:513
INFO -     chrome://browser/content/tabbrowser.xml:_callProgressListeners:563
INFO -     chrome://browser/content/tabbrowser.xml:onStateChange:757
INFO -     chrome://browser/content/browser.js:_loadURIWithFlags:1011
INFO -     chrome://browser/content/tabbrowser.xml:loadURIWithFlags:7833
INFO -     chrome://browser/content/tabbrowser.xml:addTab:2365
INFO -     chrome://browser/content/tabbrowser.xml:loadOneTab:1522
INFO -     chrome://browser/content/utilityOverlay.js:openLinkIn:436
INFO -     chrome://browser/content/utilityOverlay.js:openUILinkIn:194
INFO -     chrome://browser/content/browser.js:BrowserOpenTab:2145
INFO -     chrome://mochitests/content/browser/browser/base/content/test/general/browser_tabopen_reflows.js:null:105
INFO -     Tester_execTest@chrome://mochikit/content/browser-test.js:752:9
INFO -     Tester.prototype.nextTest</<@chrome://mochikit/content/browser-test.js:672:7
INFO -     SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:791:59
Reporter

Comment 1

2 years ago
STR:

1) Use latest mozilla-central.
2) In testing/profiles/prefs_general.js, apply the change:

-user_pref("extensions.screenshots.system-disabled", true);
+user_pref("extensions.screenshots.system-disabled", false);

3) Run the test

./mach test browser/base/content/test/general/browser_tabopen_reflows.js

Results as per comment 0.

Although we're picking this up due to enabling Screenshots, I suspect this could happen with other user-installed WebExtensions that do things with tabs.

Updated

2 years ago
Assignee: nobody → kmaglione+bmo
Priority: -- → P1
Whiteboard: triaged
This may have been fixed by bug 1358415. Can you confirm?
Flags: needinfo?(standard8)
Reporter

Comment 3

2 years ago
(In reply to Mike Conley (:mconley) from comment #2)
> This may have been fixed by bug 1358415. Can you confirm?

Thanks for the pointer. Running on try seems to confirm that this has gone away, so I'll count it as a dupe of that bug.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(standard8)
Resolution: --- → DUPLICATE
Duplicate of bug: 1358415

Updated

11 months ago
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.