blank browserAction with extensions.webextensions.remote=true

RESOLVED DUPLICATE of bug 1353060

Status

RESOLVED DUPLICATE of bug 1353060
a year ago
3 months ago

People

(Reporter: darkspirit, Unassigned)

Tracking

(Blocks: 1 bug)

55 Branch
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID: 20170418100213

Steps to reproduce:

1. Set extensions.webextensions.remote = true
2. Set xpinstall.signatures.required = false
3. Install https://github.com/gorhill/uMatrix/releases/download/1.0.0/uMatrix.webext.xpi
4. Install https://github.com/gorhill/uBlock/releases/download/1.12.1/uBlock0.webext.xpi


Actual results:

1. ublock origin and umatrix both are doing their jobs, but have a blank browserAction popup (only the border is shown).
2. the umatrix icon is shown after a while on its button.
3. If you set extensions.webextensions.remote back to false, they are working as expected.


Expected results:

1. the browserAction popup of ublock origin should be visible
2. umatrix' icon show be visible immediately

I think bug 1353060 and/or bug 1356317 are related to this.
(Reporter)

Updated

a year ago
Component: Untriaged → WebExtensions: Untriaged
OS: Unspecified → Linux
Product: Firefox → Toolkit
Hardware: Unspecified → x86_64
See Also: → bug 1353060, bug 1356317
(Reporter)

Updated

a year ago
Blocks: 1190679
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1353060

Updated

3 months ago
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.