Stylo: `getCSSStyleRules` returns rules with null `style`

RESOLVED DUPLICATE of bug 1357716

Status

()

Core
CSS Parsing and Computation
P2
normal
RESOLVED DUPLICATE of bug 1357716
a year ago
a year ago

People

(Reporter: jryans, Assigned: mbrubeck)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

The Stylo version of `inDOMUtils.getCSSStyleRules` appears to return rules with null `style` properties in some cases.

This causes failures[1] in some DevTools tests such as "devtools/client/inspector/test/browser_inspector_highlighter-geometry_01.js" with a stack like:

getDefinedGeometryProperties@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/server/actors/highlighters/geometry-editor.js:137:11
_update@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/server/actors/highlighters/geometry-editor.js:508:30
_show@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/server/actors/highlighters/geometry-editor.js:494:22
show@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/server/actors/highlighters/auto-refresh.js:112:17
show@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/server/actors/highlighters.js:502:12
handler@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/shared/protocol.js:1082:19
onPacket@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/server/main.js:1759:15
receiveMessage@chrome://marionette/content/server.js -> resource://devtools/shared/transport/transport.js:761:7
getDefinedGeometryProperties@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/server/actors/highlighters/geometry-editor.js:137:11
_update@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/server/actors/highlighters/geometry-editor.js:508:30
_show@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/server/actors/highlighters/geometry-editor.js:494:22
show@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/server/actors/highlighters/auto-refresh.js:112:17
show@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/server/actors/highlighters.js:502:12
handler@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/shared/protocol.js:1082:19
onPacket@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/server/main.js:1759:15
receiveMessage@chrome://marionette/content/server.js -> resource://devtools/shared/transport/transport.js:761:7

[1]: https://treeherder.mozilla.org/logviewer.html#?job_id=92644572&repo=try&lineNumber=11470
(Reporter)

Updated

a year ago
Priority: -- → P2
Clearing priority for now, so it appears on :bholley's triage, but probably P2?
Priority: P2 → --
Priority: -- → P2
(Assignee)

Comment 2

a year ago
This appears to be fixed by the patch in bug 1357716.
Assignee: nobody → mbrubeck
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1357716
You need to log in before you can comment on or make changes to this bug.