Closed Bug 1357756 Opened 7 years ago Closed 3 months ago

1.07ms uninterruptible reflow at open@resource://gre/modules/SelectParentHelper.jsm:109:24

Categories

(Firefox :: General, defect, P4)

defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: mconley, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: perf, perf:responsiveness, Whiteboard: [ohnoreflow][fxperf:p3])

Attachments

(1 obsolete file)

Here's the stack:

open@resource://gre/modules/SelectParentHelper.jsm:109:24
receiveMessage@chrome://global/content/bindings/remote-browser.xml:483:15
Flags: qe-verify?
Priority: -- → P2
Whiteboard: [ohnoreflow][qf][photon-performance] → [ohnoreflow][qf:p1][photon-performance]
Component: Untriaged → General
Flags: qe-verify? → qe-verify-
Priority: P2 → P3
Whiteboard: [ohnoreflow][qf:p1][photon-performance] → [ohnoreflow][qf:p1][reserve-photon-performance]
Whiteboard: [ohnoreflow][qf:p1][reserve-photon-performance] → [ohnoreflow][qf:p2][reserve-photon-performance]
Priority: P3 → P4
Keywords: perf
We can close this out one bug 1421229 is fixed.
Depends on: content-select
Whiteboard: [ohnoreflow][qf:p2][reserve-photon-performance] → [ohnoreflow][qf:p3][reserve-photon-performance]
Mike, I don't think we should mark e10s-select regressions like this bug
as directly dependent on bug 1421229.  It's more accurate to mark it as
blocking the e10s-select bug as we normally do for regressions and I think
it's better to track them all in one place.  (Also, bug 1421229 is an
implementation bug and I'd like to keep bugmail from it to a minimum.)

If/when bug 1421229 lands, we can resolve the e10s-select bug as "fixed by
bug 1421229" and then go through its list of dependent bugs to see if they
were resolved satisfactory.
Blocks: e10s-select
No longer depends on: content-select
(In reply to Mats Palmgren (:mats) from comment #3)
> If/when bug 1421229 lands, we can resolve the e10s-select bug as "fixed by
> bug 1421229" and then go through its list of dependent bugs to see if they
> were resolved satisfactory.

Sure, works for me.
Whiteboard: [ohnoreflow][qf:p3][reserve-photon-performance] → [ohnoreflow][qf:p3][reserve-photon-performance] [fxperf]
Whiteboard: [ohnoreflow][qf:p3][reserve-photon-performance] [fxperf] → [ohnoreflow][qf:p3][reserve-photon-performance] [fxperf:p3]
Whiteboard: [ohnoreflow][qf:p3][reserve-photon-performance] [fxperf:p3] → [ohnoreflow][qf:p3][fxperf:p3]
Whiteboard: [ohnoreflow][qf:p3][fxperf:p3] → [ohnoreflow][qf:p3:responsiveness][fxperf:p3]
No longer blocks: photon-perf-upforgrabs
Performance Impact: --- → P3
Whiteboard: [ohnoreflow][qf:p3:responsiveness][fxperf:p3] → [ohnoreflow][fxperf:p3]
Severity: normal → S3
Attachment #9384075 - Attachment is obsolete: true

Going to resolve this, since the corresponding line of code doesn't seem to exist anymore? The latest implementation of SelectParentHelper doesn't appear to be doing this. In either case I think this is low impact.

Status: NEW → RESOLVED
Closed: 3 months ago
Performance Impact: low → ---
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: