Closed Bug 1357778 Opened 3 years ago Closed 3 years ago

Custom Tab: Fennc launched with the same URL as CustomTab

Categories

(Firefox for Android :: General, defect, P1)

55 Branch
All
Android
defect

Tracking

()

RESOLVED FIXED
Firefox 55
Tracking Status
firefox55 --- fixed

People

(Reporter: sflorean, Assigned: JanH)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

Environment: 
Device: Huawei Honor (Android 5.1.1);
Build: Nightly 55.0a1 (2017-04-18);
Prerequisite: Nightly is closed.

Steps to reproduce:
1. Launch CustomTab Activity;
2. Launch Nightly.

Expected result:
- If "don't restore tabs" is enabled, Fennec will open with focus on about:home.
- If "Always restore" is enabled, Fennec will open with the tabs open before was closed.

Actual result: Fennec is launched with the page/link who was open in CustomTab  for both "Always restore" and "Don't restore" enabled.

Video: https://youtu.be/WzhtpoGx0z4.
[triage]
this is P1 but we couldn't reproduce now using latest nightly.
Likely resolved by some recent patches from Jan.
Could you verify if this can no longer be reproduced?
Flags: needinfo?(sorina.florean)
Priority: -- → P1
Yup, sounds like something that should in principle be covered by bug 1352997.
Hi, 
I was able to reproduce this but the behavior is different. The STR are the same but Nightly opens 2 tabs: one with the article from custom tab activity and one about:home (expected). But when I tap on tab with the article takes me to customtab. Is this expected?
Flags: needinfo?(sorina.florean)
Hi Sorina,

I use Nexus5 with Android 4.4 to test latest nightly. I only see about:home in Fennec (after launch a tab in CustomTab). If my reproduce story is wrong, please correct me.

* Clear Fennec and 3-rd party app from task switcher, to ensure each activities are removed.
* Launch 3-rd party app, open a link by CustomTab
* Press Home key to hide 3-rd party app
* Launch Fennec, about:home appears
Flags: needinfo?(sorina.florean)
Attached video nightly_20170516.mp4
A simple video to explain what I did
I can't reproduce this on HTC Desire with Android 6 but is reproducible on Nexus 9 (Android 7.1.1). So I guess it's a tablet issue. I will investigate more and test on different devices.
Flags: needinfo?(sorina.florean)
Hi, I was able to reproduce again with Asus ZenPad 8 (Android 6.0.1), here is the video: https://drive.google.com/open?id=0B3BJ1xO2hPJUcDQ1RFh1TnQzMlk. Following the steps from comment 4, when fennec is launched I have two tabs opened: 1. about:home, and 2. link from custom tab.
Does this build (https://queue.taskcluster.net/v1/task/d92n2oWWT92tabL7e9pQ7w/runs/0/artifacts/public/build/target.apk) fix things?
Flags: needinfo?(sorina.florean)
(In reply to Jan Henning [:JanH] from comment #8)
> Does this build
> (https://queue.taskcluster.net/v1/task/d92n2oWWT92tabL7e9pQ7w/runs/0/
> artifacts/public/build/target.apk) fix things?

Yes, the issue is fixed. Tested with Asus ZenPad 8 (Android 6.0.1) and Gmail app.
Flags: needinfo?(sorina.florean)
Assignee: nobody → jh+bugzilla
Hardware: ARM → All
Comment on attachment 8872293 [details]
Bug 1357778 - Exclude non browsing tabs in the TabStripView, too.

https://reviewboard.mozilla.org/r/143396/#review147724
Attachment #8872293 - Flags: review?(walkingice0204) → review+
Pushed by mozilla@buttercookie.de:
https://hg.mozilla.org/integration/autoland/rev/c1cc89fcaa05
Exclude non browsing tabs in the TabStripView, too. r=walkingice
https://hg.mozilla.org/mozilla-central/rev/c1cc89fcaa05
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
You need to log in before you can comment on or make changes to this bug.